Team Create does not let me invite other people

So I tried everything I could. I am unable to invite other people to team create. Keep in mind, this is not a group game, this is a game under my profile. I tried reopening studio, and pressing the … button. None of it works. Here’s a screenshot.

I tried posting this multiple times in the bug report section but it was all put under review, so I have no choice but to put it here.

Heyo! This was changed recently. To add new users to Team Create, go to Game Settings via this button:


Next, head over to the Permissions page.


Finally, scroll down, and you can add Collaborators to test, edit, or configure settings on your game.


It’d be good to have this feature still available however names entered there would by default have Manage privileges.
Either way, not for me to say, thank you for helping out. I would have spent a while trying to find that, haha.

No problem, always happy to help.

1 Like

Please do not miscategorise threads and post in wrong categories to avoid post approval. New members are unable to post in Platform Feedback for the sake of quality checking and abiding by the post approval procedure as set out in the rules.

You had a choice and you made the wrong one.