Teleporting script only works in studio:(

so I have a game Hello I am a Block and It has a section where you can teleport from the second floor to the first floor and it works in studio but when I tried it in normal Roblox it didn’t work

I’ve tried pretty much everything so I don’t know what to do

Here’s the script

local Teleport = "example part" --this is just a filler name
function Touch(hit)
 if script.Parent.Locked == false and script.Parent.Parent:findFirstChild(Teleport).Locked == false then script.Parent.Locked = true script.Parent.Parent:findFirstChild(Teleport).Locked = true
 local Pos = script.Parent.Parent:findFirstChild(Teleport) 
  hit.Parent:moveTo(Pos.Position) wait(1) script.Parent.Locked = false script.Parent.Parent:findFirstChild(Teleport).Locked = false end end and Ends the Function.

Simple Mistake. Did you Re-publish it?

Try going to file at the top left when you’re inside of your place in ROBLOX Studio and clicking “Publish to ROBLOX”. If you just click “Save to ROBLOX”, it won’t push it out as a live change to your place.

I did re-publish it and it still doesn’t work

Is team create enabled? If so, go to view in the top bar, find drafts and right click the script and commit.

When you close a script in team create, it automatically saved.

Not always. This would depend on the game settings I believe.

Sometimes you need to commit the draft for it to update.

I’m not on team create so that’s not the problem anyways