Terrain starts tearing / stops rendering when modified

When using Grow, Erode or Flatten in Studio on a large brush size, every once and awhile the rendered Voxels will “tear” creating an expanding invisible patch of terrain.

The only way to resolve this is to move your camera out of the render distance so LoD kicks in and re-renders the patch.

This happens quite frequently so its started to get annoying, since I can’t see the result of what I’m working on (happens every 2-3 minutes).


I think this happened to me once while using region tools on water voxels 2 or 3 days ago. I didn’t want to deal with it so I undid my changes and restarted studio and couldn’t reproduce it again.

I had that too, all players was saying they cant see terrain at the angles, some said that it gets too laggy when terrain dissapear

Make sure you have all the required parts of the bug reporting format, otherwise your report may not be investigated: How to post a Bug Report

It looks like this reproduces fairly consistently, I’m just doing this in the Village template game. Zooming out so LoD kicks in and then zooming back in fixes the weird terrain hole, as does saving and reopening the place.

It appears to happen in chunks (note the hard edges along the void).




This problem only occurs when a new crater is made in the terrain. This can be done using rocket launchers, grenades or other explosive tools. I noticed this bug when I started working on testing my explosive weapons in studio in solo mode and in server mode.

1st example - https://gyazo.com/f5a5d51313e5fd763877fdd62a2e3fa0
This GIF shows me blowing up completely solid terrain and the third crater in has not rendered properly as I can see through to the other side except I cant walk through it obviously because there is still a wall of terrain there it’s just not rendered correctly.

2nd example - https://gyazo.com/3f1d8c6765115cd3169a95629b8aa273
As you can see from this next GIF, the more I blow up the non rendering terrain craters the bigger the invisible rendering hole gets.

This problem is not just happening in studio it also happens when I play the game as well. I have tested this on my computer as well as my Iphone and with graphic settings set to the max and the same rendering issues occur. Also the bigger the blast radius the bigger the invisible holes become.

I if this is a roblox problem which I think it is, then I hope they can fix it because it ruins my game.

Here is the repro file, just shoot into the side of the mountain until you see a big invisable hole

I have had that happen before sadly. I was so confused, haha. Thanks for the solve though.