Terrain tool glitching a lot

i am (or was) building a game, and the starting zone is a cave, i had to reset my pc so the file got deleted, i didnt build too much anyways, so i started to rebuild it today.

after getting the base of the grass, i was going to make the cave with the terrain tool, but when i added a terrain bit, this happened
since the platform is just the right size, i want the terrain to not cover it too much, so i always add small bits of terrain and use the grow tool from there, but i cant solve this problem.

as the size, since i want to add small bits, i use 1 as size value, i tried to make it bigger rto see if the problem was solved but it just got worse.

this is a picture i sent a friend of what the zone looked like before i resetted my pc

please help


So terrain runs in vertices, when a new peace of terrain is attached a new joint and there for a new vertex is created. There isn’t much else you can do seeing as each Terrain type reacts differently with the # of polys for how rough or how smooth they are. When you’re trying to make ground like that your best option is to use a method like this. It might take a bit longer but that way you can have more control over where the vertices are and how they react.