Tool doesn't work once I put it into a players backpack using a script

  1. What do you want to achieve? Keep it simple and clear!

I am making a system in which gives the player the tools they have purchased in the past.

  1. What is the issue? Include screenshots / videos if possible!

Everything works, except when I put the pickaxe into the player’s backpack using a script you can no longer use the tool. If you walk over the tool, it will work but if you put the tool into the player’s backpack using a script it doesn’t.

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

I have tried all sorts of solutions, like disabling the scripts in the pickaxe until it’s in the player’s backpack. This also doesn’t happen with this pickaxe only, it happens with every tool that I know of.
robloxapp-20220313-0830254_Trim.wmv (2.3 MB)

The video does not work, seems like it wasn’t uploaded correctly.

But if I understand the question:
If the script is putting the tool into game.StarterPack, make it so that it puts it into game.Players.PlayerName.Backpack.
You are saying that you’re putting it into their backpack, so I have no idea without a given script snippet and video.

Oh sorry let me try and reupload.

I might have made this too confusing, but basically when I clone a tool into the players backpack the scripts inside of the tool no longer work.

Are you sure the scripts are being cloned too and not being disabled?

I haven’t looked at the video, but I might have a guess:
Are you cloning the tools on the client side, and are the tool scripts a server script? If so, this is simply occuring because the server scripts aren’t running, as the tool simply doesn’t exist on the server.

Good point - I waited for them to respond so I could confirm whether it’s a localscript or a script that they’re cloning it with.

This is probably the issue. I am using a local script to clone the tools, so that’s probably the issue. I’ll use a normal script and let you know if the problem is fixed.

For the video not working, convert it to mp4 and it should work :slight_smile:

Thank you so much! The problem is solved! :slight_smile:

1 Like