Tool not working (Making the Player float when used)

  1. What do you want to achieve?

So I’m making a horror game, and you need to get a key. But it’s not working.

  1. What is the issue?

When you use the key, it does this:

  1. What solutions have you thought of so far?

I’ve tried looking online, but I couldn’t find anything, not sure if its because I’m a beginner.
I appreciate all the help I can get! (Note: I literally just started making tools, so it may just be that I’m a newbie)

The handle / main part of the tool (or any other parts in the tool) is anchored, unanchor it and it should be fine


It doesn’t make the player float anymore, but now theres a new problem
(Only the handle is with the character)

Try unanchoring the other parts then.

Everything fell down now

Use qPerfectionWeld, just search in the toolbox, also make sure you anchor it back.

[30 charssssssss]

You’d have to weld the tool’s parts together. You can try qPerfectionWeld

1 Like

Yes, it works now, thanks for the help everyone!

1 Like

Weld the parts together (30 charrrrrrrrrrrrrrrrrrrrs)