Tween Function Not Working

So I’m trying to make a frame tween to white and it’s not working at all, any suggestions???

Also no errors in the output either :confused:

local plr = game.Players.LocalPlayer
local char = plr.Character

--// Modules
local Methods = require(game.ReplicatedStorage.Functions)

function BootUp()
local Screen = script.Parent.Screen
Methods:Tween(Screen, .5, Enum.EasingStyle.Cubic, Enum.EasingStyle.In, 0, false, 0, {BackgroundColor3 =,255,255)})

First thing I’d tell you is that if you’re using Color3 values which go to 255, use Color3.fromRGB, not Also, I don’t know what “methods” module is and it doesn’t look like it’s doing anything useful to you, just use the simple TweenService roblox already has

LOl, well its a module im using to make tweening less redundant

Right, perhaps it’s good but I don’t know what it is, so there’s no way to analyze your code and see if there’s an issue with it when it comes to your use of the module.

It’s nothing to do with the module it’s probably the problem, also Im using the module other places and it’s working so its obviously not the module

Okay then yeah try to fix the color3 problem, see if that changes anything, but my guess is that this isn’t the problem, because if the Tween worked probably then it would just appear that the color is instantly changing to white, but you’re saying that the tween isn’t working at all which makes me think it’s not changing color at all.

Alright so I just endeavored the Color3FromRGB and it’s withal not working for some reason im not sure why I genuinely thought it would fine-tune it

Oh wait, I see the problem. Do still change the color thing, but you did Enum.EasingStyle twice in a row when you should’ve had Enum.EasingDirection after the first Enum.EasingStyle

1 Like

Oh rats well thanks man im always making stupid mistakes

1 Like

Wait its still not working for some reaoson

You should actually show the Tween function in the module. It seems as if the code to run the function is fine (after corrections), so I assume the problem has to be in the module’s function itself

Are you actually playing the tween?

Oh sorry wrong version

local ts = game:GetService("TweenService")

local functions = {}

function functions:Tween(length, es, ed, ra, br, dt, property)
	local tween = ts:Create(self,, es, ed, ra, br, dt), property):Play()

return functions

If you’re using method (colon) syntax, self will be pointed to the table the function is called from, so you’re basically attempting to do:

ts:Create(functions, ...):Play()

Make the object the tween will be played on as a parameter of the function, like the first one, and pass it as an argument when calling the function:

function functions:Tween(obj, length, es, ed, ra, br, dt, property)
    ts:Create(obj,, es, ed, ra, br, dt), property):Play()

Methods:Tween(Screen, .5, Enum.EasingStyle.Cubic, Enum.EasingDirection.In, 0, false, 0, {BackgroundColor3 = Color3.fromRGB(255,255,255)})

I tried changing the syntax and it didnt work

Check your entire output for errors pertaining to the script. Post the updated code of the module’s function and calling the function in the other scrip

@Crazycat4360 He is actually playing the tween, so that’s not the issue here
@OP’s code:

Yeah i checked everything well like I opened my output and its blanker than my face when i was trying to fix this problem

1 Like