Typing in the script editor is extremely slow in macOS High Sierra/Mojave/Catalina

This is has been an issue for a while now, there are multiple devforum posts about it. If I remember right it has to do with the DPI of the display on the newer 5K Mac models (like mine). I’ve noticed however that it gets significantly worse if you have multiple Studios and/or Roblox Player open at the same time.

Haven’t seen too many devforum posts recently about it, seems like the bulk of the people experiencing it experienced it around a year or so ago. My Mac is pretty old (it’s before they days where they started making them thinner and thinner, and removing things like the USB ports - or was that just a rumor?), and it was fine up until about a month or so ago. Recent updates to the OS and Studio itself have just made it worse - right now, I’m in one Studio window, with an open baseplate, and I can’t switch my POV without it lagging every 2 seconds for 3 seconds.

2 Likes

Another update: One of my Twitter followers said that a complete factory reset of his/her Mac, combined with removing every ROBLOX plugin on Studio, and then installing another one that toggled the ROBLOX UI editor on/off, fixed the issue.

It’s a pretty simple solution, but I’m not up for the factory reset part. I’ve had my Mac for over four years and I have a lot of stuff on here I wouldn’t want to lose (backing it up on a USB, if big enough, would be a pain)

And generally, I don’t know if this fix would work for me/others. There have been other solutions mentioned here on the Dev Forum that were far less invasive that I’ve tried, and they didn’t change anything for me.

That Twitter follower did mention that the current/new ROBLOX UI editor on Studio was part of the problem.

1 Like

Probably my last update on this thread - a factory reset has seemed to have fixed the entire issue.

As stated before, didn’t want this to be the solution, since it involved the erasing of all my files gathered through the years - I believe I’ve backed up most of the memories on a flash drive, but I’m sure there were others that fell through the cracks.

Regardless, the issues I’ve mentioned before are no longer, but the biggest question I have is if this issue will return or not, as I really don’t want to have to factory reset my Mac every time this happens.

2 Likes

Would you be willing to post here if this issue occurs again? I have the same problem and I can no longer use Roblox studio. I’m debating re-imaging but I imagine the problem will just come back and I’m not willing to regularly re-image my computer.

2 Likes

Of course. And so far, it’s been a week or two since I factory reset and everything’s been good…

knock on wood

2 Likes

I am having this issue on my Windows 10 computer. It just started about 3 days ago. Whenever I open a script I get this warning in the output.
image

Edit: After restoring windows, my Roblox studio is back to working properly.

4 Likes

My Mac has been experiencing increasingly an increasingly laggy script editor for the past month or so. I’m going to run a full factory reset like @CoolJohnnyboy recommended. I’ve changed my display profile and deleted and re installed studio multiple times. Editing the scripts in a separate window seemed to fix the script editing problem but overall studio is just one big lag party. I’ll update this after the computer is reset

Update: Studio is completely fixed. Took a bit for the factory reset but it’s totally worth it.

2 Likes

I’m also experiencing this issue, however I don’t really want to factory reset my computer… There’s four years of work on this computer (not only mine but my family members’ as well). This started for me yesterday and I don’t know what I did. I’m running a 2014 Mac Mini on macOS Mojave. Anyone else found a way to fix this without a factory reset?

Edit: As @Spraden said, editing scripts on a new window seems to get rid of the script lag, but for some reason when it’s a tab in Studio, there’s input lag. So far this is the only thing that’s laggy; dragging around parts, resizing, etc is all normal.

3 Likes

After awhile, the script becomes laggy again in a separate editor.

The only fix really is to factory reset it.

2 Likes

But how does it happen? And is it a ROBLOX Bug? I just don’t feel like Factory Resetting my whole entire computer to fix a ROBLOX Bug is something I want to do. Anyone found a fix besides factory resetting?

2 Likes

It’s definitely a roblox bug. I’ve asked around before to no avail, the only real answer seems to be to wipe your computer. You can try storing a backup, and then uploading the backup once you reset it

1 Like

So I’ve talked to ROBLOX Support about this issue and the only solution that they found that solves this issue (besides factory resetting your computer) is adding another user to the computer and using ROBLOX Studio on that account. Hope this helps anyone who is currently experiencing this issue!

3 Likes

My solution and recommendation is to just install Windows via Bootcamp on your Mac. Even if you factory reset your Mac you’re only postponing the problem as it’s likely to reoccur (I only used two Apple laptops for Roblox Studio but they both became afflicted and were rendered unusable), not to mention Roblox doesn’t seem to care about Mac bugs or at least they don’t take them nearly as seriously as Windows and that’s why so many bugs on Mac go unfixed (I stopped reporting Mac bugs because it became clear to me they just don’t fix them - even after over a year). I was a huge Apple person but Roblox and Mac do NOT go together. Roblox staff literally told me they couldn’t fix the problem and that they stopped trying. I’m not trying to give Roblox a hard time as I understand their resources are EXTREMELY limited, but it’s just an example of how Mac is a third class system in terms of how they respond to bugs. Roblox doesn’t care very much about fixing Mac bugs; that’s a fact. Spend the $150 on Windows 10 and use it for Roblox Studio (if you can afford to). In my opinion the entire Mac version of Roblox Studio should be listed as BETA and NOT a full release.

Also, it’s not just the script editor that presents issues. When I stopped using Mac for Roblox development I timed it and it took over 5 minutes to load an empty baseplate; that’s truly unbelievable. I love Roblox and am very happy they wish to expand their share of the market, but in order to be taken seriously as a viable option for Mac OS development they will need to do some incredibly significant work and hire new staff to focus on improving Roblox Studio on the Mac so that, at the very least, it functions in the most BASIC sense of the word. Until then Roblox Studio on Mac should be marked as a beta WIP.

This may seem harsh but accepting money from Mac OS developers while you fail to provide them with a functioning development software seems problematic and the fact that you stopped trying to fix this issue seems like it borders on unethical (the last statement is made because I was told by the Roblox staff that they had given up).

I have outlined this issue in further detail on my website:
https://www.vissequ.com/index.php/2019/06/06/use-windows-for-roblox-studio-do-not-use-mac/

Addendum: Roblox should buy a Mac. I’ll pay for it :slight_smile:
But I’ll honestly send Roblox one of my Macs if they’re willing to use it. Millions will benefit if they put even a little effort into fixing this problem and I’d be happy to help.

9 Likes

I’ll contribute to the pot fund for this! :joy:

I’m completely unable to even create a model without crashing in places with less than 10 parts, using a MacBook.

6 Likes

Do you think we should try crowdfunding?

I’ve had multiple non dev forum members contact me personally after I posted the article on my website and they all share the same sentiment. We are upset that we are overlooked and that Roblox accepts our money but refuses to fix the problems which prevent us from using the software for which we pay to support.

The most logical thing is of course to reduce our payments to Roblox and I’m reducing myself from OBC to BC but the dream is that one day all Mac users will be able to use the Roblox Studio application (or at the very least Roblox admits they cannot support a public release version of Roblox Studio for Mac OS and changes its status to beta.)

3 Likes

As stated in previous posts about this issue, it would extremely helpful if you posted your Mac OS, Processor, Memory, and Graphics info when you report an issue. We are well aware of the issues plaguing the Script Editor.

We have a backlog of over 1000 issues, and they must all be prioritized for a team of less than 15. This is no small task, and requires smaller bugs to be unprioritized over more critical issues. Additionally, we have never been able to regularly repro the Script Editor problem reported, but we believe we know the cause and are always on the lookout for more information.

As for getting us a Macbook… I assure you, we have plenty of Macbooks.

7 Likes

It’s been over a month, any updates so far?

Yes, I have recently encountered the issue. Not sure what causes it. Might be after I installed a plugin. It has never been that slow before until I decided to install a new plugin.

:computer: Sloooooooow typing…

And currently, I’m working on the scripts outside Studio just to avoid the issue and only use Studio for the purpose of reading.


Reinstalling Studio proves ineffective.

Current specs:
macOS Mojave 10.14.5
MacBook Air(11-inch, 2015)
1,6 GHz Intel Core i5
4 GB 1600 MHz DDR3
Intel HD Graphics 6000 1536 MB

3 Likes

If it started happening when you installed a plugin, have you tried using Studio wit plugins disabled? Can you link the plugin?

3 Likes

I don’t believe it is plugin-specific, because this plugin is newly published and posted in DevForum. I’ll check tomorrow with all my plugins disabled(doubt this works, because other users reported the result, maybe restarting Studio once will help after procedure?)

If you wonder which plugin, it is the Plugin: Local File Importer (Import Images from your Computer!). However. I am doubting that installing a plugin slows it down as I might’ve been oblivious during development(lack of sleep I guess).