Typing in the script editor is extremely slow in macOS

I’m having a similar issue; but, I’m using macOS Big Sur on the 2020 MacBook Pro. It occurs every time I use the script editor. In the meantime, I have resided to VSCode in the meantime.

Opening script editor has been lagging the whole studio lately for me.

For me, this issue occurs 100% of the time with the default color profile. Deleting files in ~/Library/Preferences and reinstalling Roblox had no effect.

Edit: for anyone using the Generic RGB Profile solution I recommend trying the sRGB profile instead, colors should look significantly better and the performance is the same.

1 Like

Thanks! I would recommend the same thing. I don’t know why Roblox hasn’t optimized their software for years to perform well with Macs that have P3 wide color gamut displays.

Mac OS Big Sur, Mac Mini M1 w/8gb ram, two 1440p displays. Script editor runs horrible unless detached from studio window (And even then it’s slow). MacBook Pro w/m1 processor and 512gb SSD runs fine w/script editor after changing RGB profile. Changed RGB profile on Mac Mini and no difference in performance.

After having this issue consistently for 2 weeks I found out switching my color profile from color lcd to generic rgb or multiple other profiles fixes the problem

I’m also having this issue. This happens to me every single time I open Roblox Studio and try typing in a script. Uninstalling Roblox and reinstalling made no difference. It’s been happening for quite some time now.


Whenever I try typing in the Roblox Studio script editor attached to the studio window it is very slow to type, almost as if it’s lagging. However, when the script window is detached from studio into its own window it seems to respond quicker to my typing with less lag.

This is my current colour display profile setting. When one of these two options is enabled as the colour display profile, typing in the script editor within the Roblox studio window reacts very slowly to my typing, making it “lag”


When this sRGB colour display profile is enabled, it actually makes typing respond quicker within the default script editor in the Roblox studio window. However, I’d rather be using the default colour profile if possible and I don’t want to have to keep switching every time I need to write some code.


This is happening on my Mac too. I’m pretty sure it started when I first opened a shared game with team create, but I just figured it was slow because it was in team create. However, every other place I opened (including non-team create ones) has this slow typing bug now.

Right, it’s both. Deleting files and changing the color profile. For me, when just changing the profile, nothing happened. It only worked after i did both.

Maybe it only applies to Mac computers with batteries (MacBooks)?

I would recommend SRGB instead of RGB.

Yeah, same. Changing the color profile constantly can be a huge chore. I am not sure why Roblox doesn’t work well with P3 wide color gamut displays.

I didn’t have to do both in order to fix the performance. Interesting… :thinking:

The color profile solution is for wide-gamut P3 displays made by Apple, Mac Mini does not come with a display. You are probably using a display that is not affected or is affected differently.

This is the monitor I’m using (x2) https://www.bestbuy.com/site/lg-ultragear-27-ips-led-qhd-freesync-and-g-sync-compatable-monitor-with-hdr-displayport-hdmi-black/6401809.p?skuId=6401809

Does it have a P3 wide color gamut display?

Man, I regret upgrading to Big Sur.

1 Like

Why so? Is it because of the script editor issues?

I’m also having this issue on both of my macs and the script editor lag is unbearable. Almost impossible to get any work done.

Extremely frustrating, please do something to address this asap.


Happens on an empty baseplate.

This happens 100% of the time.

Have you tried doing this in the meantime?

1 Like

Again, this issue has struck me.
I was able to solve it on my old MacBook, and I do know how to fix it.
But I want to know Roblox if you need anything from me before I do fix it.

Still having this issue for over a year. On macOS Big Sur, latest studio update, no beta features enabled.

I’m able to reproduce this 100% of the time.

It makes developing impossible.

In the video I typed fast but it took the script editor time to catch up.

1 Like

Does switching 3D view tab or display Studio on built-in display can solve the issue in your local?