UI Changing Place In-Game?


I’ve basically been trying to get my UI to not move position in-game for the past 30 minutes. Basically, in studio it’s in the middle in the screen like it’s supposed to be, but in game it changes. I’ve tried using Auto-Scale Pro, offset AND scale, both didn’t work.

How do I fix this?

That means you’re using offset, instead of scale. Try checking the parent of the UI and see if it’s positioned/sized to offset. If it is, change it to scale.

How it works
{XScale, XOffset}, {YScale, YOffset}


I know how it works, and as I said,

The value right now is {USED, NOT-USED},{USED, NOT-USED} (I’m using scale.) It didn’t work. I’ve tried {NOT-USED, USED},{NOT-USED, TUSED} and didn’t work too.

Edit; Nevermind, the size wasn’t scaled. It was offset. BUT, the position is scaled and still doesn’t work.

Second Edit; Scaled the size, a little changed but the position still isn’t where it’s supposed to be.

The size would still sorta move it offscreen.
Try using a UIScale object https://developer.roblox.com/en-us/api-reference/class/UIScale

1 Like

Tried that with the converter, didn’t work too.

Make sure the anchor point is 0.5, 0.5.


What if I’m using TweenService?

It would still work 30

1 Like