UIPageLayout not working when Parent Frame is Parented under another Frame

https://gyazo.com/5af28ecbaea6717237cfe3df98b3f969

UIPageLayout_Repro.rbxl (18.6 KB)


How do I get it to work properly?


UIPageLayout not working when Parent Frame is Parented under another Frame

I haven’t tested it with other kinds of Gui Objects so you should test it with other Gui Objects as well

Umm, so i downloaded your Repro without editing anything and it works for me :thinking:


also works via Local servers, is the issue appearing in Online mode or you tried in Play Solo ?

I am having issues with it in Play Solo and Local servers

Does manually calling UIPageLayout:Next before trying to move the page with your scroll wheel fix the issue? I often have to do this when I use UIPageLayouts.

No matter how hard i try to replicate the issue, i am unable, it always work for me,
At best you can check if the problem comes from your Studio if you attempt the repro via another PC

Note : i don’t believe your way of adding UIPageLayout is wrong, it’s pretty much the usual way of setting it up

No it doesn’t help.

I reopened the place, restart my computer, it doesn’t seem to help.

I will try it with an Online Game

(Edit)
works fine in an Online Game

That’s means that it’s broken for my Studio, perhaps because I have Accurate Play Solo on?

I’m not exactly sure, i just believe abnormal behavior (because the UIPageLayout should be working for whatever option you’d normally play with) could be files being corrupted by your own PC if you had odd situations such as suddent turn On/Off, That you edited studio, or if you’re using Studio on win8, 7, vista or Mac and they might not support the feature (at this point it’s could be reported as Studio Bug)

What i’m saying right now might not be related, but i know it could be the actual cause, for example, my current PC do not detects my PS4 Controller even with the solutions offered while my old PC worked with it just fine, Therefore i have quite the issue making Xbox Compatible, but perhaps i have not looked enough.

Yeah, I’m not too sure why you’re experiencing this issue. You will most likely have to file a bug report and report the specs you have. UIPageLayouts are capable of working under other frames and objects, so in general this is not a bug specific to UIPageLayout but rather whatever operating system you’re running on.

I’m unable to reproduce this issue.

To be sure, you aren’t using an old Studio build (e.g. a Future is Bright demo build), and haven’t been editing fast flags (either manually, or using third party tools)?

If you go to File -> About, what version of Studio is shown? Have you tried reinstalling Studio?

I haven’t modify Studio in anyway, it broke itself.


I actually found out how and why it broke

Using the Emulator

I found a new issue

Same problem but in Game on Touch Devices it’s not functional at all.

How can I make it work properly?