Unable to create badges


I have been attempting to upload a particular image for an in-game badge, but every single time I attempted to create a badge this is displayed:


I have uploaded the image as a decal to make sure that uploading images works. This doesn’t add up, in my opinion.

What I don’t get is that the image is within the correct guidelines for a badge image - 150x150 and using the template required.


I’ve attempted to upload the above .png multiple times since yesterday. I don’t know whether it is my antivirus or if the image itself has issues (this one was saved in 8-bit bit depth). Searches through the Devforum and the Wiki only bring search results from before the move from web uploading to Studio only.

Thanks for any help in advance.


I’ve had this issue with a .png file. Just try duplicating the picture and uploading that one or redownload


Since Roblox seems to not recognize the image due to its lack of transparency, I’ve decided to attempt to upload another version of the image with a transparent ring around the actual displayed image.


I doubt that this will work, but it’s worth a try, I suppose.

Update: It didn’t work either :S A buddy’s attempting to upload it since it refuses to upload on my end.
Update 2: It didn’t work on my friend’s end either. I’m suspecting something’s wrong with my image.
Update 3: The same friend also found out that Studio was using the entire filename of the image and causing it to not be uploaded as a badge at all. If that isn’t a bug, I don’t know what it is anymore.


Reported here:

If the solutions in the thread don’t help (change bit depth of the png) then add onto that with your repro cases.


how do u do that? i don’t know how to change bit depth. I hire ppl to make these designs and idk how to use paint

1 Like

You can use i.e. https://www.getpaint.net/ and it has options available to change bit depth upon saving.


still not working and i tried all conversions


Try saving it as a JPEG and uploading it again

1 Like

I did and still fails


Unfortunately, it seems that badge uploading in general is broken all around.

I would throw in a report but sadly I’ve no permissions to do so, so I suppose I’ll just have to wait. :confused:


Make sure you have builders club I think thats needed and etc.


According to this Developer Hub article Builders Club doesn’t appear to need a requirement in order to upload badges. As demonstrated in the provided images I did have the funding to put in a badge.


Email Roblox Support at the offical website or use the bulletin board it says in the new devfourm we could do that possibly.

1 Like

A full member just got around to reporting this:

In the future, if you have an issue like this and you think it is a bug, use the post approval procedure described in the rules.