Unable to union some parts

Hey! I am making a crate opening system, but I am having problems since I updated the look of the crate.

What are you attempting to achieve? I have a crate opening system, and trying to make it work with a new crate.

What is the issue? The crate itself is a model, but whenever I try to union it some error shows up and says Selection contains CSG-incompatible instances

That’s what the crate looks like.

What solutions have you tried so far? I have tried to remove the egg mesh, I tried renaming all the parts but it doesn’t work.

The reason why I have to keep it as a union is because the crate changes size when it opens.

Most meshes can’t be unioned so maybe don’t put the egg in the union or weld all the parts.

I ungrouped it, and it worked. But now all the textures and colours (colors) are messed up, is there anyway to fix it?

Before being Union

After being Union

Unions can’t have different materials.
Also, when you were selecting the items in the Properties window to Union, did you have anything other than BaseParts or Unions selected? If you select the model or a mesh as well then it will error.

1 Like