Unable to upload a building I made


The building part count numbers just below 2,000, though I’m not sure that’s an issue. When I upload the model to my group it either goes immediately to 3%, 8%, or 10% so far and then the blue bar turns red, fills the rest of the bar and says; “Error:Upload Failed. Please try publishing again.” I’ve tried at least 8 times by now.

What options do I have to troubleshoot this issue? I also tried uploading it to my own models, same result.


If you can’t publish it, save it in a local file.

Do you have any reproduction steps?
What are your computer specs?
Did this occur all the times?

Have you ever checked your netw- never mind.

This is unusual. I’ve never encountered these errors.


I’m guessing this is Windows? Did you try restarting computer, and studio? Reinstalling studio might be a good step to take after this, if it still doesn’t work.


I saved it as a local file, turns out it’s 50-51 MB and it’s only a small house. Not sure why. I tried uploading other items and they’ve worked. My computer specs are as follows;

i5-6500 @3.20GHz Quad-core, 16GB RAM, GTX 1060 6GB.

Internet speed; 6 ping, 160MB download, 15MB upload.

I’ve restarted my computer by now and Studio just updated about an hour ago and I tried uploading it after that, to no avail.