Union Anomalies

Recently while working on this building I was attempting to union the bottom floor and something interesting happened. Unfortunately I dont have any video or gifs because this happened a while ago and I have only encountered it a few times.


Pictured above is showing the division between the two floors.

I started out with two ‘floors’ each made of 3 solid blocks in kind of a horseshoe shape. Going to union the bottom ‘floor’ would mysteriously delete the upper, already unioned, floor. I tried everything I could think of, ununioning the top, which then caused only half of the top to be deleted when I attempted to union the bottom.

Top view with different colored blocks showing the makeup of the horseshoe shape.65955af74e0b8212681176aae5f64d21

The only solution I eventually came to was completely deleting all of it and starting from scratch and for some reason it worked that time.

I understand this isnt really much of a development support question but I was wondering if anyone has encountered anything similar to this and if anyone has any reliable solutions other than completely starting from scratch.

Yeah, there are a lot of rare bugs and glitches in the current CSG system, and unfortunately there’s not much of a way to solve them. If you want, you can try CSGV2 by going into your Studio Settings and enabling it. Just be warned that V2 has its own little bugs.

1 Like

I find that I can avoid a large number of CSG errors by using nested unions as infrequently as possible. That is to say, instead of unioning multiple unions together, you would take them apart and union their components into a singular union.

3 Likes

To expand upon what chipio said, CSGV2 works pretty well but I wouldn’t use it for everything as it has a higher triangle count than V1. Also another thing you can do to get different CSG generations via unioning different parts separately or by offsetting some parts properly. Another thing you can do if you find that either of these two methods are a bit too time consuming is by using this plugin(Thank @EchoReaper) to help solve some union issues.

3 Likes

I’m not much of a builder but i’ve experienced this issue many times but i’ve always just ununioned the part and unioned it again and it has always fixed.
This does not always work usually does work for me.

1 Like

Regardless, I would seriously advise against unioning things for the sole purpose of reducing part count (unless if you’re working with unanchored parts, which in this case you are not). You will instead increase lag, as the current engine does not accumulate lag based on part count but instead by polygons, of which you will not change by the simple act of unioning parts together.

this is actually a common error that i’ve run into before.
if you can’t separate the union that keeps disappearing, then chances are you’ll need to make the union again in some sort of different way.

1 Like

Are you sure it has a higher triangle count? I thought the new one was more optimised in that way. :thinking:

The reason it fixes the problem is likely because selection order matters when creating unions. There are sequences of selection order which cause broken behavior like that, but when you take it apart, Studio selects the parts in a different order. When you union them again, since they’re not selected in the same order, the problem is resolved.

I eventually settled on deleting all of the bricks associated with the part and redoing it. It worked the second time. It seemed quite random.

1 Like

That was the thing with my problem though, the part that was disappearing wasn’t even selected.

that’s the nature of unions for ya.
if i helped in anyway, glad i could.

1 Like

While this seems to be another unioning bug this is not quite what I encountered.

When I was attempting to union the bottom section, the already unioned, not selected, top section was deleted.

You’re issue was occuring when everything was selected.

An entire section of the building for me was being deleted when it wasnt even selected.