Verticies won't move on X-Axis

Hello everyone! I am extremely new to Blender and I am currently making a vehicle, an Audi S6 2012.
The issue is that this selected circle shown in this picture won’t move on the X-Axis side (to the right side), but it moves on all the other axes. I’ve tried to go on the y-axis while hitting G and selecting the circle, though it still won’t move, any solutions?

Press G + x to move on x Axis, that should fix it

1 Like

Already tried that, doesn’t work

What? it should, select the circle, and in Object mode press G, then X, and drag

Probably your best solution is that if you are new to blender (Extremely new) the last thing you should do is a car.

It works on object mode, but it moves the hood too. When I try to do it on edit mode, it won’t move.
Is it possible to only move the circle on object mode?

Try double G + Double X or try G + Shift X

Still doesn’t work, tried both modes too…

Then, select the circle, press P to separate, and then you can move it in object mode.

Alright, it works now, thanks!