Viewmodel animation not playing even though IsPlaying is true?

  1. What do you want to achieve?
    I just want an animation to play with my viewmodel. I currently everything set up ready for the animation, so it should be playing.

  2. What is the issue?
    The issue is that my animation doesn’t play even though AnimationTrack.IsPlaying is true, and that the Animator:LoadAnimation() returns the AnimationTrack. However, it is not playing the animation at all.

  3. What solutions have you tried so far?
    I searched everywhere for the solution, however, there isn’t an answer that helps me in any way.

--I have self.loadedAnimations and self.settings loaded up. loadedAnimations and settings is a table.
function handler:reload()
	if not self.loadedAnimations.reload then
		self.loadedAnimations.reload = self.character.Humanoid:WaitForChild("Animator"):LoadAnimation(self.settings.animations.viewmodel.reload)

And here’s the settings script if you need it:

local data = {
	weapon = {
		name = root.Name;
		auto = false;

	animations = {
		viewmodel = {
			reload = root.animations.reload;

Here’s the hierarchy as well:

And video footage of it not working:

Thanks to anyone who helps me, I would gladly appreciate it. I don’t know why it wouldn’t work.

Solved on Discord by himself ^