Viewportframe not showing on a SurfaceGui

Trying to figure out a way to show a character’s model on a sign. So far the only method I know is trying to put a viewportframe on a surfacegui but it’s not working.

What I am trying to achieve: Screenshot 2021-05-20 100747

What I have: Screenshot 2021-05-20 100923 Screenshot 2021-05-20 101020

I have no clue what I am doing wrong, any ideas?

you should have a Camera inside the viewport frame then put the currentcamera property of the viewport frame to the camera instance that you made

Still getting the same result with the camera in the viewportframe itself

i guess you should check out the viewport frame tutorial…

Read this, it might help you achieve this effect without viewport frames

NEVERMIND! Did some research and found another post with this same problem. Their solution was to parent the SurfaceGui to the PlayerGui and Adornee the SurfaceGui to the target which worked. Originally my SurfaceGui was parented to Workspace

Result: Screenshot 2021-05-20 104940

2 Likes

Target as in the player or the part?

1 Like

The part, the adornee of a gui is what part it’s attached to.
Also you shouldn’t bump a post 2 years old, if you don’t know.