Weird-Looking Import from ROBLOX to Blender

Hi there!
I’m currently having some issues with importing buildings from ROBLOX to Blender. In this particular case, I am dealing with some weird looking parts. I don’t know how to describe it so I will provide an image of both the Blender version and the ROBLOX version:

It looks like this in ROBLOX (Studio):

This has never happened to me, and I am trying to fix it. I have tried replacing the parts with Blender, but it didn’t work out.

If you can, please assist me with this, as I never experienced such a thing in Blender, and it only seems to be happening with ROBLOX Studio imports.


Looks like it’s adding a bunch of extra faces. Roblox’s topology when imported into Blender is generally terrible, and it presents itself in ways like this. You could try removing doubles and normalizing the faces but your best bet is to import it in separate, smaller pieces.

1 Like

The texture might be low quality.

Thank you! I’ll try doing this now!

This started happening to me today. I fixed it for the most part by merging all of the vertices by distance and recalculating the normals on the outside.

I just deleted the extra faces that were on top of the actual faces.