When adding a part to workspace when having a selected another part, the new part becomes a child of that selected part

I don’t know if this is really a bug so I will just ask here.
How would I fix this:
Basically, let’s imagine Brick1 and Brick2.
I’ve selected Brick1 and now, I want to add another brick (via the above bar, Home).
I click that and Brick2 (new brick) is now a child of Brick1 instead of Workspace.

How would I turn that thing off. It didn’t happen to me. This isn’t the only time when it happens. Basically also when you insert seats, etc.

Thank you!

I mean that seems like a logical thing, doesn’t seem wrong. Why is it annoying you?

Hi! That’s not really a bug. The ‘Insert’ section in the ‘Home’ tab explains, “Place a Part into the workspace”, meaning that it’s its intended purpose. I’ve looked up for this in Studio settings and I haven’t found any option to enable/disable that behaviour.

As you said, this also happens when inserting BasePart objects through the Advanced Objects menu - they automatically appear inside the workspace regardless of the selected object(s). When you insert UI objects (Frame, TextLabel, etc.) they are parented to StarterGui.

This is based on how the objects are and should be used. For example, in general, we don’t want to parent a Part to another Part. However, if you really need that, follow the next steps:

  1. Copy the ‘child’ Part, Brick2
  2. Right-click the ‘parent’ Part, Brick1 (either in the displayed 3D world or in the Explorer)
  3. Click “Paste Into” or, as a shortcut, Ctrl+Shift+V

A faster way, though, is to drag Brick2 into Brick1 in the Explorer.

1 Like

No, I mean, before, when I inserted something, it appeared in Workspace automatically and not inside that selected part.

I misspelled now with not.
Meant to be:

I click that and Brick2 (new brick) is now a child of Brick1 instead of Workspace.

Oh, lol, that makes more sense :man_facepalming:
I’ve tried to replicate the bug but I haven’t succeeded so far…
I’m sorry I couldn’t help :frowning: