Why won't it teleport on click?

Mine should work. Just copy and paste it.

1 Like

It’s a button like this,

And here is the explorer if you need.
image

Can you stop ignoring people trying to help you? I already found the solution for you. Try @AwokenTy method.

Would this be a localscript or a server?

The issue isn’t all the buttons although once one button is pressed then it should disappear.

Either also can. It doesn’t matter in this context.

I am not ignoring, I am trying every solution that is here and simply replying. If I reply late, doesn’t mean I am ignoring.

You’re discussing another problem rather than the OP’s main issue.

Either one is fine. It’ll all work the same.

So, this is in the starter gui?

Again, it can be in any local client’s container.

1 Like

Tried it and I get this error and I don’t teleport.

Players.TheKman2019.PlayerGui.Bus stop.ScrollingFrame.Airfeild.Script:4: attempt to index nil with ‘HumanoidRootPart’

Use WaitForChild on the character and the root part.

Wait make it a local script. Not a server script my bad.

Same Error.

@ItzMeZeus_IGotHacked I’ll try it.

Make sure it’s under the button, if that’s what you’re trying to achieve.

Do my code in a local script and you’ll be fine.

I did, for some reason just errors.

Error:

Players.TheKman2019.PlayerGui.Bus stop.ScrollingFrame.Airfeild.Script:4: attempt to index nil with ‘HumanoidRootPart’

Can u show me the error with my code?

If this is in the startergui then remove the script. Then put a localscript in the button.
In localscript:

script.Parent.MouseButton1Click:Connect(function(player)
	game.ReplicatedStorage.RemoteEvent:FireServer(player)
end)

In Script in serverscripts:

game.ReplicatedStorage.RemoteEvent.OnServerEvent:Connect(function(player)
	if player then
		player.Position = CFrame.new(368.676, 14.803, -521.64)
	end
end)

And sorry my last post had an error so this should work!