Windows incorrectly docking in Studio, malformed windows

This is the same thing for me and I put a bug support message in and nobody has gotten back to me about it. Here’s my problem:

I’ve tried reinstalling, clearing cookies, and restarting my laptop and nothing is correctly working.

My specs:

|Processor|Intel(R) Core™ i7-4710HQ CPU @ 2.50GHz 2.50 GHz|
|Installed RAM|12.0 GB|
|System type|64-bit operating system, x64-based processor|


I’m confused. This workaround should just get the window back to its default position, with the viewport back in the main window (though it apparently doesn’t work for everyone), I don’t understand how it changes DPI if it’s how it should’ve originally been.

@Inf1n1tylt Yep, because re-installing studio clears the files that store the layout properties (I’m not sure where layout stuff is located anymore unfortunately). This isn’t an ideal workaround imo because it resets all that. I like when my layout works.

@MrGreystone Very strange! I guess this workaround does not work in this case. Try clicking the actual place title, rather than the background bar?

@Bulldo344 I began experiencing this issue myself as well.

The layout seems to be in some sort of weird invalid state, each time play is started, all pinned windows flash, and all windows resize several times, which causes a lot of slowdown. It also resets the order of all pinned drawers (which is fairly annoying), and then eventually after some flickering and resizing it goes back to how it normally looks. I haven’t gotten around to reporting this properly yet but it seems that the layouts are quite complicated in their implementation, and seemingly weren’t designed very safely (or what they’re built on wasn’t) since a lot of these issues are entirely invalid states for the windows to ever be in.

@ElephantMesh Would the layout files themselves be beneficial to reproducing and fixing these issues?

I’d really like some info on how and where the layout information for all the windows (e.g. docked and pinned states) is stored, especially so I can try and understand why these issues happen for myself. I have experienced a lot of weird stuff where issues will actually even persist across studio restarts. That makes no sense to me, it suggests whatever is going wrong is also present in the file(s).

I feel like it’d also be beneficial to the people experiencing these issues to know exactly what files store the layout information, so they can reset the layouts, since these issues are completely workflow breaking. The viewport issue for example makes it impossible to use studio effectively, e.g if the viewport is off-screen.

P.s the detached viewport issue acts like the viewport is separate from the container, it behaves like any other floating window. The container itself (thing with the titlebar) behaves a lot like the pinned drawers, unpinning one unpins them all, so, my hunch is that it is using the same feature (like its a PluginGUI without a border, and placed inside a container), but there is some way to get the viewport into an undocked and floating state, but, with no titlebar, it can’t be docked again, or moved, or anything.


Try deleting Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio from the registry. It worked for me with a problem with the old UI


The only workaround I have is to manually dock Roblox Studio whenever it bugs out, and do that every single second. It’s very annoying and tedious to do everything every single second, and I just want this bug fixed. I’ve started to have this issue whenever this new docking update was first launched and I haven’t gotten a response back from bug support, a actual helping hand from Roblox Support all they have said for me to do is do the same thing I’ve been doing.

1 Like

@SubtotalAnt8185 Is correct, the docking information is saved in the registry in that specific folder. Deleting that will reset your layout to the default.

We encourage you to report any bugs you see. Unfortunately, specific bugs have been challenging to track due to the fact that we are unable to reproduce them internally. This is one of the bugs that we are highly interested to track down, but have no reproduction of.

FYI: For this specific bug, thanks to the countless hours spent by our community, we have narrowed it down to having several sessions running along with floating widgets. You can effectively avoid it if you do not end a session with a floating widget, or only run one session of Roblox Studio at once.

@Bulldo344 Please DM me any bug thread that you have posted related to the docking update. Thanks!


Has been happening to me almost every time I’ve opened Roblox studio in the last 1-2 weeks, especially when I’m running 2 Roblox studio sessions at once. Really annoying since I frequently (literally all the time) run two Roblox Studio sessions at once due to my current project. Glad to see I’m not the only one experiencing this, hoping this gets fixed soon. :pray:

1 Like

Continuing the discussion from Windows incorrectly docking in Studio:

Forgot to mention, sometimes instead of just the docking getting messed up, my camera bugs out and I can only move with my mouse in a circular motion. Also doesn’t let me look up or down, and then when I exit the tab and reenter, the docking bug occurs. Sorry if I didn’t explain that well but here’s a video (do keep in mind, this MOSTLY happens when I have 2 studio sessions running):

And then here’s a photo after leaving the tab and reentering:

When I go into a script, it sometimes stays on my screen permanently even when I go back to studio view. Text in scripts also turn fully white sometimes, and it stays like that permanently as well.


This happens to me every time I try to open more than one Studio client. Even a lone Studio client has plugins docking incorrectly in play mode or just randomly.


Not sure if this is the same issue, but Studio has literally become unusable for me without having to restart it every 5 minutes because the screen just goes completely white when trying to play-test it. This is a crucial issue that needs to be looked at and I believe it has something to do with the recent UI updates to Studio as it only just began occuring once they appeared for me.

Edit: Resolved as of the current time. I will edit this post once again if this issue occurs again.


Can confirm receiving the same issue, cannot play test my games in studio because of this. The main game window is completely separated from studio itself.

1 Like

This is also happening to me aswell.

I am unable to open multiple windows of roblox. Which is kind of annyoing when i need to have two clients open to test my game.

1 Like

Well, this is happening to heaps of people and its great i must say.

1 Like

It happens to me aswell, script editor is almost unusable and I must have undocked windows to make sure I can do anything. Roblox studio is beyond broken.


Same, I really don’t know why. Hope Roblox fixes this as quick as possible.


god sake its happening again, they’ve broken docks again.

this is definitely related to a previous issue: Random UI Fragment Appearing after Run Testing (New UI)


they really need to fix it. I literally can’t do anything lmao.


I have a game that I need to finish this month. But because of Roblox, I can’t.


Studio pretty much nearly unusable for me where local server testing is concerned. I tried testing with 2 players, reloading studio, deleting a load of older plugins, and this issue still happens.

Last time I responded to one of these it was disregarded as a plugin fault, I don’t think it is.

This seriously needs a fix though, only been happening since the docking update, which has given me more issues than benefits.

If I undock, and then redock that same viewport, it will start working, but this is definitely a roblox issue, not a plugin issue.

Roblox, pls fix


Come on, i can’t work normally for 15~ days straight. It’s just impossible to do anything


If anyone here is still having issues, delete the registry key Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio\LayoutSettings in regedit. This will reset your studio layout and will most likely fix the problem.

Edit: If you are having another issue that is not fixed after deleting this key, try deleting the higher up RobloxStudio key.