“No Network” on IOS App despite my WiFi working fine

As seen in the images my WiFi is working fine

I have the latest installment of the Roblox IOS App

here’s my device details

iPhone 15 Pro
iOS 17.4.1 (21E236)

App version 2.619.508

  • I tried reconnecting my WiFi
  • Ending tasks
  • Restarting my device

Expected behavior

I expect the app to open normally

6 Likes

It looks like you are in airplane mode, if you are on an airplane, they often block access to certain websites, maybe they blocked roblox.

3 Likes

You forgot to disable Airplane mode :uhh:

4 Likes

IMG_0822
clears throat loudly

4 Likes

While I will admit that turning airplane mode off might help, I think everyone forgets that you can still use wifi on airplane mode - and, to my knowledge, doesn’t affect how that wifi performs (at the very least, not in a way that would be causing this issue) - if you don’t believe me, look at how the speed test was done with airplane mode on

And yeah this should have gone in #bug-reports:mobile-bugs probably

I am connected to WiFi despite airplane mode being on and it has full functionality, I am actually replying with Airplane mode on right now

@Brylan_Leske
@EpickDoe
@karlos_800
@walywhale


I am unable to change the category and this was automatically selected when I was creating the topic, I didn’t see a sub category for “Mobile App” so I picked “Other” @cpguy5089

3 Likes

Are you from Vietnam? The only way to fix this issue is to use a VPN.

1 Like

I am experiencing this aswell.

iPhone 13 Pro
iOS 17.3.1

I’ve pinpointed the root cause (or atleast on my end) to be the ‘Local Network’ app permission. When declined, Roblox pops the ‘No internet’ error.

The issue is resolved when I re-enable Local Network (through Settings > Roblox > Local Network)

Quite a number of people are experiencing this issue.
https://x.com/coco_x3xroblox/status/1776016557472174333

Question: Why on earth is this Local Network permission a requirement? I can’t think of any reason or feature that Roblox may need this for.

9 Likes

Oh, i did say no to that permission, thank you for pointing it out!

edit it did fix my issue


@thebrickplanetboy no I am actually in USA

3 Likes

In that image you shared now airplane mode is now off

Also said no to this setting because Roblox was wanting to access other devices on my network. Still cant think of why in the world this is a requirement??

2 Likes

Thanks for the report - we’re looking at this issue now.

6 Likes

They added local network to patch these false no network errors while on wifi

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.