403 Error When Attempting To Toggle Studio Access To API Services As A Collaborator

Reproduction Steps

  1. Join a team create session that you are not the owner of
  2. Access game settings
  3. Toggle studio access to API services
  4. Attempt to save

System Information
11th Gen Intel Core i7 @ 2.50 GHz, 16 GB, NVIDIA GeForce RTX 2060

Beta Features
Advanced Explorer Filtering, CSG Version 3, Face Capture, Intuitive Debugger, Live Animation Creator, New Characters Controller, New Text Chat Service, Notched Screen Support, Save Rig with Animation, Scale Factor for Models, Selection Improvements, Team Create Connection Indicator Rework, Upgrade Shorelines

Expected Behavior
If collaborators are not meant to be able to toggle studio access to API services, the button should indicate that via being grayed out or some other UX communication. Otherwise, the server should not return a 403 error.

Actual Behavior
Despite being able to toggle studio access to API services as a collaborator, attempting to save returns a server error in the form of a warning.

1

2

Issue Area: Studio
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2023-03-07 00:03:00 (-05:00)
Date Last Experienced: 2023-03-07 00:03:00 (-05:00)

1 Like

Does it get enabled though? This sometimes is the case.

No, it was never able to enable it. I tried it on another friend’s team create as well and still ran into the same issue. It seems that only the owner is able to.

I think these two are related, if you look at the console warning it lists the same error code “403” (which, as an HTTP error, means the client does not have access to the resource, and is also called “Forbidden”):

I have this same error :frowning:, but for everything related to the Game Settings page that updates something, for example I can’t change the game description and I get this same error.

Thanks for the report. I filed a ticket to our internal database.

1 Like

Hey @Bobytoeburrito ,
This is expected behavior, as non-TC owner you can’t toggle studio access to API services. We are not planning on changing that, but we will add a separate feature ticket to disable the UI - although we can’t confirm right now when we will work on that. For right now, only have the owner change the game settings. Thank you for flagging this issue!