After update 3/7/20: Unable to Open Place in Studio

Currently, I am unable to open Roblox Studio to edit a group place. A link to the place is here: Alpha Framework (Busy) - Roblox

I was in studio and it has been working fine for several days. A few minutes ago, I opened a new studio window and they all closed to update (even though I have beta feature for safe updates enabled…?). After it updated, it was unable to load the place file.

Studio freezes right after the green bar loads at the bottom. I have tried several times to open it again and waiting a while to no avail. I have also tried opening it both via the browser Edit button and via the Open menu in studio. Closing other applications does not seem to make a difference. The place is a Team Create place and is part of a group.

Waiting long enough ultimately ends up with this error message:

System specs: Windows 10 Education (version 1909 build 18363.693), 32gb RAM, Intel i7 8700 processor, GTX 1070 Ti graphics card, 1 Tb SSD.

Here is a video of me attempting to open the place via browser and studio freezing as described.

Here is a log file from Studio that may be relevant.
log_1253A_1.txt (14.8 KB)


Launching Studio via the website bypasses the beta feature. You should use File > Open From Roblox to navigate to the place and open it. If Studio is insufficient, then please make a feature request and describe why you still need the website for developer-related needs, as the Create page is not guaranteed to continue existing for the next 10 years.

Sorry! It seems we were experiencing a backend outage which was affecting live games as well. This should be resolved now.

Still unable to open any place in Studio from either the website or the Studio client. For team create places, my client starts “(Not Responding)” on the “Opening Place” screen. For non-team create places, I load in and start seeing some parts (no meshes/unions) and then get “(Not Responding).”

This error also appears: image

1 Like

Same issue, however using BTRoblox to download the place file and trying to open from that seems to work without any issues.
Opening game(both website and studio)

Opening from file downloaded from BTRoblox

1 Like

Restarting my computer seemed to fix the issue.

Doing a total uninstall and fresh install of studio fixed it for me!

This is great to know, I wasn’t aware! Studio is mostly sufficient, though the annoying thing is if I go through studio, I have to open the main game’s place first in order to open a sub-place of the game. I can make a feature request for opening places without opening the main game place first.