Autorecovery / autosave forcibly deselects textboxes and blocks all keyboard input in complex files

In complex place files, whenever an autorecovery file is created, Studio locks up for a moment, forcibly deselects any text boxes you’re typing in and blocks all keyboard input, including in the script editor.

This is jarring and incredibly frustrating. This issue manages to catch me typing in the properties window extremely frequently, and messes up my typing when I’m programming and pulls me out of my work.

This operation should not block Studio so intrusively. These same symptoms do not happen in simple places (e.g. default baseplate).

At the very least this shouldn’t deselect my textboxes. It would be awesome if saving could be made asynchronous like publishing though.

To reproduce, you must have a complex place file open (i.e. an entire game). Set the autorecovery interval as low as it can go so it’s easier to catch, type/wait in a properties widget text field or the script editor until autorecovery creates a file. If the file is sufficiently complex, the properties field will deselect, or your typing will be fully blocked in the script editor while Studio saves the autorecovery file.


I only started to notice this starting this week but it may have been happening for at least 2-3 weeks, or even much much longer and my games just weren’t complex enough until now.

My C drive is an older SSD, and all of my other drives are WD Black drives, so my storage hardware is not unreasonably slow.



I can provide my entire place file privately. It’s this game: Be an Alien: Renewal - Roblox
I managed to reproduce this with this file too though: Complex file.rbxl (284.4 KB)

I only have the Safe Studio Updates beta feature enabled.
Disabling all plugins does not help.

These videos demonstrate:

Properties text field forcibly kicks me out / deselects.

Text input into script editor is blocked, interrupting my typing.


If to reproduce it you need to set the auto save interval low, why not just set it high for yourself so it’s less of an issue?

Even if you set it to something reasonable like 30 minutes, you’re still going to encounter the problem every 30 minutes.

1 Like

Setting it to a higher value could lead to a bigger data loss if the file was shut down unappropriately. If auto-save is a thing, we expect it to work properly.

Bugs like these should be fixed asap. (Right now my auto-save is disabled because it lags out the game, even in simpler circumstances, while manual saving doesn’t.)

Also, this reported bug has happened for many months (10+) here.

Setting it low is just to demonstrate the problem more effectively. This interrupts me destructively well over 15 times in a 2 hour development session set to 5 minutes.

1 Like

Thanks for the report, we will take a look.


This is still happening and even at 5 minute intervals destructively interrupts me constantly while in the middle of working on the datamodel (i.e. duplicating and renaming instances). It is infuriating and severely harms my workflow. If publishing can happen in the background, it would be really nice if saving could too.


I made a post about this recently before discovering this report done years ago. Would love to see this resolved!

Hey everyone. So sorry for the wait. We’re finally getting to this, and reworking our entire bug report process. See this more recent post for updates ^^