Bodymovers flinging parts with lower gravity

Yeah, I’m able to reproduce this. Let me check if changing the ownership manually fixes it.

in my trash can game it already sets it manually but with a server sided gravity value, you may be onto something.

I used this script to set the ownership to the client and it still happens:

local grav = workspace.Gravity*script.Parent:GetMass()
local body ="BodyForce")
body.Parent = script.Parent

body.Force =,grav/1.5,0)

	local character = hit.Parent
	if not character then
	local player = game:GetService("Players"):GetPlayerFromCharacter(character)
	if not player then

I’m not sure what the problem is. This is pretty strange.

here’s a test with it changing from server to client every 5 seconds.

still only happens after interacting with the part.
so weird.

I’m not allowed to send in bug reports to the devforum so I don’t really know what to do for now.

1 Like

I’m pretty stumped. This seems like a bug related to the character controller or some physics optimization.

I would just keep on developing and assume it will be fixed. I really can’t imagine this is a problem on our end.

I have one more solution I wanna try that I thought of when you mentioned the gravity being different on client and server.

I’m thinking if I re-set the gravity each time the network owner is changed it might make a difference. or if that doesn’t work, fire a remote function to the client asking for the same formula but done on the client.

if that doesn’t work I have no clue what will.

I tested it with grav/1.25 and it didnt happend or I tested to short

still happens when I try it with that.

still happens with both of these solutions. I’ll just wait till roblox does something about it.

Hey you should try to disable “retargeting” property under workspace

still happens, what does retargeting change?

My bad , try to change “PhysicsSteppingMethod” to Fixed


I’m not sure about the exactly utility of retargeting properties but it fixed my problems of animations (arms acted weirdly on some rigs during custom animation). Try the PhysicsSteppingMethod to fixed

this actually worked, thank you so much.

I think roblox probably changed the physics stepping default from fixed to adaptive.


Nice ! No problem

char char char

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.