Cannot open new studio window from within studio

This bug occurs when I do some action in an open studio window that would normally result in a new studio window being opened. This includes:

  • Starting test servers (via ribbon bar with any number of players, or via pressing F6 or F7)
  • Opening a new studio window (via Ctrl + N, or the New button at the top left on the ribbon bar or dropdown menu)

When doing any of these actions, the cursor flashes to the windows loading cursor for a brief moment and then goes back to normal, but no studio window is opened. This prevents me from using test servers or opening new studio windows from within an active studio session. Here is a video of the bug:

I first noticed this happening yesterday. I am unable to test changes to my game that require 2 players to test, so this is a big hindrance to me.

I can reproduce this bug in any studio window 100% of the time, including if I do the following steps:

  1. All studio windows are closed and no RobloxStudioBeta.exe processes are running in task manager
  2. Open Roblox Studio via Windows start menu
  3. Open a new baseplate by clicking the New icon in the top left or clicking the Baseplate template on the home screen
  4. Click the New button again or start a test server (these do not open new windows like they normally would)

System specs:
OS: Windows 10 Education 10.0.19041 Build 19041 x64
CPU: Intel Core i7-8700 @ 3.20GHz
GPU: NVIDIA GeForce GTX 1070 Ti
RAM: Dual channel 32GB @2666 MHz

DXDiag & Studio log dumps can be provided upon request.


what is Windows 10 Education?
Im only used to working around home and pro.

Please try to reinstall, we are unable to reproduce this internally

If that does not work, please provide logs. We have instructions here How to post a Bug Report. They can be included in the original report without needing to wait for an engineer to request them


I excluded the files because of this warning on that “How to post a Bug Report” page:

I tried uninstalling, removing all Roblox AppData files and registry keys, re-installed and the issue still existed.

Then I tried rebooting my computer. After rebooting, Studio went through the “Studio updating…” process, and once it finished and opened, everything works properly now.

I just installed studio so I’m not sure why it had to update after rebooting my PC, or if that was involved in the fix at all, but it is working now.

Thanks for the help and fast responses, everyone :pray:

1 Like

Just for future reference, the rest of that post explains where you should send them: Logs / Crash Dumps / Other Bug Files. I’ve edited it to clarify this.


On the hierarchy of available features, it goes something like this:
Home < Pro < Enterprise < Education

Education has pretty much every feature Windows has to offer. I get 1 free personal lifetime license through my university.

can you dm me the things it has, so we don’t flood this with useless info

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.