CanvasGroup Beta: Group Transparency on UI Groups

Enabling is not the same as being able to launch in-game

1 Like

You should update the “Known Issues”, the 5th point was implemented and the crashing doesnt appear for me

I’ve been able to do it since beta release

You have to realize that fixing bugs and making an entire new class isn’t easy to do.

yeah but I hope they will able to get it released… i mean like its slowly rolling out :face_holding_back_tears:

It is live on production right now. You should be able to publish games with it.


When will CanvasGroup’s features be supported on widgets?

Clipping with UICorner is not supported

CanvasGroup’s stand-out features are overridden by widgets

I’m facing the same issue show here in the post below. On MacOS , I am able to reproduce this issue every time by forcing either component of CanvasGroup.AbsoluteSize to be 0. I tried the same steps to replicate the issue on Windows, but the CanvasGroup worked as expected.


Unsure as to where to ask so I’ll ask here.

In a case where I need a lot of image labels (for a colour wheel to be specific), is it more performant to use CanvasGroups to display the colour wheel over just using a frame + image labels? I can’t just use a single image as that wouldn’t allow me to show brightness and saturation properly.

For reference, I have 91 of these small image labels which compose the full colour wheel:

1 Like

I have been encountering the blinking/corrupted display result whenever I tween a canvasgroup’s size to, 0, 0, 0) or just a very small size, my specs of my development device are:

  • Intel Core i5-10300H CPU @2.50GHz
  • NVIDIA GeForce GTX 1660Ti with Max-Q Design
  • 1920x1080

Sometimes the frame would just show up as corrupted, or in some cases it just won’t even be visible.

I’m getting really bad results with this feature.

All of these screenshots come from different computers.

all of the UI is wrapped in a CanvasGroup to allow smoother transparency transition when transitioning to hide it instead of using the Visible property. It’s also experimentally used on UI panels, and optics which are a critical gameplay feature.

As a result, the text and icons are blurred or straight up unreadable depending on conditions.

This happens occasionally, somewhat inconsistently, and makes the feature completely useless if this behavior isn’t gonna be able to be changed. Is there a solution?

Besides, what is the point of this feature with this horrible automatic quality control behavior enabled? UI should NEVER be blurred like this unless there is literally no way to render it without downscaling because of hardware limitations which don’t apply for the computers which took the screenshots shown.


Is your GraphicQuality level set to automatic? Our internal system would switch render levels based on your framerate, etc. And the determined render quality level would affect how the final result would be.
You can check this on Shift + Ctrl + F2 and check FRM config showing under the performance section.

I am also happy to help check your place’s status if you don’t mind dm me a set up of your current scene.

Graphics quality in the first image is manually set to the lowest option, it’s the same in the second, but i’m not sure what it is in the third since it’s from a community member.

Can I know why automatic quality adjustment can’t just be manually disabled? In my game, It’s critical scopes render at high quality and it would immensely speed up development to implement CanvasGroups in them, considering I need to clip a reticle image that may be resized with variable zoom optics.
I’m going to try it anyway but i don’t want to end up having to go back.

Also, the extremely pixelated icons in the last screenshot aren’t behind any layered canvasgroups.


It does not seem to work with UIStrokes

Group transparency set to 0
Group transparency set to 1




Any updates on this? I’m experiencing the same issue. Everything placed inside the CanvasGroup is invisible.


Canvas group breaks once its been nested inside 4 other canvas groups

So basically the canvas group is no longer responsive (however you can still move it around or change it size, but thats about it) and will pretty much become a single color image
Example of that: (Left text button is technically working as intended and the right one is broken entirely)

Another thing with this issue is that you can “technically” (not really, also that’s exactly what ive done with the left button from the image above) get around it by first placing the canvas group in a safe spot then placing it back in the nest again. This will make it retain its original visuals however as stated before however you will be unable to change any of its properties (along with anything parented inside) other than position and size

Place to replicate the issue:
CanvasGroupNestIssue.rbxl (56.8 KB)


It seems that SurfaceGuis like to “blank out” a lot with this feature, which is strange as at points newer instances generate fine. This very well could be the necessary memory failing to be allocated, but it seems strange considering my setup. Hope to hear a response soon in regards to this.

Current Specifications:
CPU: Intel(R) Core™ i5-4690K CPU @ 3.50GHz
RAM: 16.0 GB
GPU: NVIDIA GeForce GTX 1660 Ti
Displays: 1920 x 1080



Text on a 32:9 aspect ratio under canvas groups is barely legible with an ultrawide display. This is happening both in studio and the client app.

Current Specifications:
CPU: AMD R9 5950X
GPU: NVIDIA GeForce GTX 3080
Displays: 5120 x 3440

Hey, when’s it going to be fixed if there are text buttons with the AutoButtonColor property enabled under CanvasGroups? I just realized this had been acknowledged months ago, and I’m struggling with the problem I encountered a few minutes ago. Just wanted to notify if this case was set aside.


1 Like

I am not 100% sure if this has been seen/spoken about already but it would be great if animations would work within WorldModels

Currently having my ViewportFrame and a WorldModel within a CanvasGroup stops animations from running until the Canvas needs to update for any reason, such as TweenService.

Here is an example of it working without Canvas:

Here is an example with Canvas:


I’m having the same rendering issues as some other people in this thread. In my WIP character customization menu, I click a button to switch to a tab with shirt options, but it doesn’t update visually until another mouse event fires inside the CanvasGroup. (Notice how I move my mouse out and back into the frame and it fixes itself)

It would be nice if UICorner had an option to set the corner radius for each corner individually, because the only reason I opted to use CanvasGroups is so my frame can have round corners despite having additional frames on the top and left edges. (If UICorner had properties for each individual corner, I could just add one to each frame and not use CanvasGroups at all)

1 Like