Changing Packages Causes Player to Fall Over?

I’ve changed the package a player has equipped, but every-time they walk- or even sometimes when their package is changed, the character just falls over and can’t get back up. Their legs are also occasionally in the ground when they walk.

I’ve tried to anchor the Torso during the change, making the player’s body teleport up a little bit to make room, but the problem still persists.

I’ve tried playing around with the HumanoidStateType but not sure if I did that correctly.

Here’s the code I’m using:

for index, value in pairs(package:GetChildren()) do
	value:Clone().Parent = playerInstance.Character

Am I doing something wrong? What can I do to get rid of this issue?

1 Like

I think you’re better off using HumanoidDescriptions. Look here for more information:

Roblox wiki showcases a tutorial to how you can implement this: Tutorial


I’m currently using a package that’s been imported into Studio as a model. It’s also R15 and, I can’t seem to find the majority of R15 properties in HumanoidDescription properties?

(Things like LeftFoot, UpperTorso, etc.)

Is there any other way to do it without using HumanoidDescriptions?

1 Like

Doesn’t seem to be reliable support for R15, but I may be wrong.
When you clone the parts to the player, it can be overwhelming because of the weight you’re putting on the character. You should toggle the massless property under your character OR try removing the collisions on the instance- CanCollide.


You should be able to do something like this with That’s how I’m replacing packages right now.


That worked! But- now my character is tilted back like this:

Is this because I’m not replacing the HumanoidRootPart? I tried to, but there’s no Enum property for it(that I can find) using this API.

You shouldn’t be replacing the HumanoidRootPart. Its invisible and it essentially what makes your character to move.

Looks like that tail looking thing could be colliding with the ground: image

1 Like

Special thanks to @uJordy and @Kampfkarren for helping me find the solution.

I was able to resolve this issue by using ReplaceBodyPartR15 while setting the package’s parts to be mass-less.

1 Like