Chat scrolling zooms camera in/out

Since the last release, trying to scroll through the chat history in-game results in the camera zooming in.

I have determined the cause of the issue is the ScrollingFrame used to display chat messages has the Active property set to false

18 Likes

Thanks for the report. We’re looking into options for a fix.

9 Likes

I can confirm this is happening with all ScrollingFrames in my game as well and not just the chat.

4 Likes

Bumping this thread because this issue is still persistent with all ScrollingFrames. Is there any update on a fix for this?

5 Likes

Yes, I still have this issue as well and it’s causing quite an inconvenience.

5 Likes

Also hoping this will get fixed soon…

Nevermind… turns out this happens if the scrolling frames ‘Active’ property is set to false

1 Like

Any updates on this?

It’s still occuring and it’s very annoying.

It occurs on all Scrolling Frames that allow you to scroll on, and doesn’t occur in Studio.

Seems to have started happening after the scrolling frame update some weeks ago.

2 Likes

Basically, for guis, it works if you set a scrolling frame to “Active” (true).
But for physical scrolling frames (on parts), it works only in studio …

This has been an issue for around 2 months already. Looks like Roblox forgot about it.

2 Likes

Roblox please fix this, as a person who has to scroll up for chat history of some players breaking the rules in game or trying to moderate the server with my camera zooming in is really annoying and makes it harder than before.

1 Like

This is insanely annoying. It occurs on all scrolling frames. Haven’t been able to find a workaround.

Windows 10
4k display
Latest Roblox version

1 Like

@subcritical
Is the Roblox team still working on a fix?

1 Like

Bumping this because it seems as people are still having problems with this. I’m going to show you how to fix this and it’s actually really easy.

Step 1:
Run a game in Studio and look over in the Explorer. Scroll down to the Chat and copy the “ChatScript” and its children.

Step 2:
Exit the Test and paste everything you copied into “Chat” section. Go to ChatScript > ChatMain > MessageLogDisplay. Open it.

Step 3:
In MessageLogDisplay, you’ll see a variable named Scroller and the Active property is set to false, change that to true and now it should be fixed. Like the OP said, the issue is the Active propery being set to false, but they don’t go into detail on how you can fix it.

I hope this helps people having issues with this because this has been a very annoying bug and I’m glad I could finally figure out how to fix it.

6 Likes

I bump this thread, this error is happening me in the chat and any scrolling frame. What i do is start studio and test play. Roblox still don’t fix this issue 3 months later. I hope this gets fixed.

1 Like

I’ve recently released a game and the issue still exists and it does get annoying. Hope this gets fixed

This issue got so bad on my game that I had to script in an auto lock for zooming when the mouse is hovering scrolling frame UI elements.

Please fix it. It gets annoying fast.

1 Like

This issue should’ve been resolved in October.

Setting any Scrolling Frames Active property to true will fix this issue. It has for me at least.

This issue has been resolved as of the current Roblox update.

1 Like

I don’t know about anyone else, but this has not been fixed for me.

ScrollingFrame Active property is set to true and the camera is still annoyingly zooming in and out while I scroll.

1 Like