Chromebook: Shift Lock does not work

Description
Any time you enable Shift Lock on a Chromebook and hit the shift key, nothing happens. The game still uses everything like a normal camera. I’m not sure if this was a purposeful or is a bug.

Background
The Roblox app is downloaded off the google play store on Chromebook, just like you would on a tablet, which I’m assuming Roblox recognizes Chromebooks as, but in-game it gives you the option to enable shift lock.

This has been a bug ever since I installed it, but I could not post on the DevForum at the time.

This happens in all Roblox games, not just a select amount. I’ve tried everything from reinstalling the app to wiping my entire Chromebook.

Steps to reproduce:

  • Open Roblox app on Chromebook
  • Go into a game
  • Pause menu
  • Enable Shift lock
  • Notice that nothing changes

While I realize there are most likely not a ton of people who play on Chromebook seeing as there isn’t a ton you can do, it’d be nice to see this fixed.

135 Likes

Don’t want to bump it but it needs to be done. Still to this day this issue is happening. My device is not being recognised as a mobile device, because I am getting the 10-slot inventory, however, not getting the following:

  • Cursor is not appearing.
  • Shift lock is not working.
  • I only have mobile movement modes.
  • And much more.

I can create a whole list of things wrong/that don’t work on chromebooks, if you’d like me to do this.

42 Likes

I am also having this issue. The black cursor appears fine when hovering over GuiButtons, but the white cursor does not appear at all, so there’s no way to know where my cursor is on screen until I open the ESC menu, or hover over a GuiButton.

It’d be nice to have touchpad gestures added too, as Chromebooks (well, mine anyway) do not have a right mouse button.

24 Likes

Update, the shift lock switch STILL does not enable shift-lock. Getting pretty annoyed with this. Nothing has changed. Thanks for the support by the way!

31 Likes

The Reason Why I believe this happens because You downloaded it off the Google Play store It is still considered a mobile app since the Play Store is meant for mobile apps. If this is in your game you can add a button or another key that will register to activate the shift lock if you don’t know how to do that you can view this article How To Make Touch Screen/Mobile Device Screen Shift Lock Button/How to Enable Shift lock while Clicking With Different Buttons.

4 Likes

I need this for all games, and seeing as a chromebook is mainly used as a laptop and not a keyboard, we have access to shift-lock. However, when we try to activate it, it does nothing. I’m not really interested in adding scripts in my game to make it work, but rather for it to work across the platform.

10 Likes

Ah look, another bump. Fortunately, Roblox has fixed the issue with the cursor, however, Shift Lock still doesn’t work. Games also recognise my device as a “mobile” device, not a Laptop like it is. They made it so that we can toggle shift-lock in our game settings, however, whenever I toggle it on, nothing happened.

I found a quick patch for Chromebook users that want their device to be recognised as a Laptop, not mobile. While you’re in the loading screen of a game, spam random letters, space bar and move your cursor around alot. This way, it will think you’re not on mobile, for whatever reason. Now, you can play the game as it is intended, not with the view mobile players get.

All I am asking is for someone at roblox to see this and find a patch. Thank you very much.

9 Likes

The reason this happens is chrome books cannot download exe files. The Chromebook is considered a mobile device because you have downloaded it off the play store. Sorry that is a problem. I believe it should be looked into making a different solution so chrome OS users can play the full version of Roblox.

7 Likes

I don’t want to revive this topic but it still really needs to be fixed.

I can’t play so well in some games and when I want to use shift lock it won’t work.
Roblox definitely needs to fix this because I’m pretty sure every chromebook user is being affected by this.

I really hate that this is happening.

7 Likes

Weird that Chromebooks don’t have priority for the engineers.

I think that there is a simple solution to fix this: treat the OS of Chromebooks (Chrome OS) like it is Windows or Mac OS.

Please fix this issue, many others have trouble with this bug.

3 Likes

Screenshot 2020-09-03 at 8.23.50 AM
Why is it like this for me?

You cannot use the web browser, you have to be on an android device (obviously) and open up the app.

Chrome OS uses android therefore it has to be installed via the google play store.

Nothing else

1 Like

That would be writing new code though. It’s easier to build in keyboard support for android & iOS than it would be to make a whole new client for chromebooks.

Chromebooks are built on the Android kernel, which makes it more like android than linux. They could write linux support, but that’s a whole other situation, still coding a new app.

2 Likes

@BIoximus
But whenever you try to install an app on the play store through mobile it just offers it for that device only. How would I change that?

1 Like

YES! Finally somebody understands! Shiftlock never works for chromebook, no matter what I try.

8 Likes

i hope they fix this alot since aton of the games i play in are meant to be played in shift lock

1 Like

i found out how to enable it you have to press it when it says off so it says on then press shift it worked for me!

2 Likes

you actually have to press the off until it says on then exit out and press the shift key

7 Likes