Client/character freezes when holding right click on top of window [repro]

  • windowed mode in-game
  • jump
  • at the top of your jump, right click and hold the top of the window (the bar with minimize, maximize, and close)
  • it anchors your torso and your limbs dangle there from other people’s perspectives
  • hang there as long as you like while holding right click on the top of the window
  • used to gain unfair advantage in survival games et cetera
  • tested with windows 10

Thebatman2020 showed it to me and Buddyism in-game and all 3 of us were testing it haha.

2 Likes

Reproduction steps also work with Windows 7 and Windows 8/8.1

this is amazing

Still an issue.

2 Likes

I think it freezes all local scripts as well, or at least loops.

This is a pretty bad thing in survival games like @Polyhex’s Super Bomb Survival and @HomingBeacon’s Zombie Rush. Players can use it to avoid danger unfairly. It’d be nice if ROBLOX fixed it.

It’s been a little over a year since this was bumped. This bug is still commonly exploited.

IIRC, TNT Rush, one of the games used in the Voltron event, had to implement a workaround that kicked players if they froze in the air for too long because this was such a common issue. Longstanding and widespread because players have had plenty of time to document and spread the exploit.

This has been around for ages

Can confirm this bug is still alive and kicking. Holding it for 30+ seconds also doesn’t appear to kick you from “losing connection”. Odd as it seems to affect everything from graphics to sound (I can hear the footstep sound stuck in a loop). My best guess is it floods the main (windows UI) loop with messages and doesn’t free up enough in the queue to allow for other threads to process.

Right clicking the top bar on windows in windowed view causes your game to freeze. This also prevents your character from being moved, and moving parts seem to not collide with your character while frozen.
This happens 100% of the time in every roblox game.

This is a fairly well known bug, but I haven’t found any posts about it. There is also another way to use this bug to walk through any wall under 1.1 studs thick.
This only works sometimes
This may be hard to reproduce but I’ll give all the steps here
Align your character flat against the wall, then push your character away slightly using shift lock and rotating your camera. Then straighten your character again and turn off shift lock.
Wait about a second, it doesn’t work if you do the rest immediately after aligning yourself.
Tap W and freeze your game, wait a bit and unfreeze. If you’re lucky and the wall is thin enough, you’ll be on the other side.

(This also works in R15 but is harder due to animations)

1 Like

I didn’t even know about wall clipping using this. I repro’d this exact noclip scenario with your steps 3 times in 20 tries. The wall was just under 1 stud thick. Crazy how easily reproable this is (I tested with r6, have not tried r15)

alternative wording of steps:

  • align yourself flat facing the wall
  • turn on shiftlock, take half a stud step back, turn off shiftlock
  • tap w and then immediately right-click-hold the window bar for a second
  • bam, other side (might take a couple tries)