ContextActionService::CallFunction does have a function for ${ActionName}

Yesterday we’ve released a new update to our game that, among other things, features an IR Flares system for helicopters. We’re using ContextActionService to bind flares ejection to F on PC and DPad Down on Console. After about 12 hours post-release, we stumble upon this issue on Roblox Analytics’s Error Report page:

Notice this part here:

ContextActionService::CallFunction does have a function for HeliFlares

Strangely enough, during my 15+ years of Roblox development, this is probably the first issue that I’ve come across that has zero mentions of it online whatsoever. Do any of you know what it means and what root causes of it might be?

So far I’ve tested the following assumptions, neither of them are correct:

  1. CAS:BindAction(...) is called for the same Action twice before CAS:UnbindAction(...) happens. I’ve tried just setting the same action twice, and CAS didn’t throw.
  2. The CallFunction is synchronous and is running for a while. I’ve tried calling CAS:UnbindAction(...) while the CallFunction is still running. Didn’t throw either.

pls help


Yeah. That’s a strange message. Usually, an error message means that something’s wrong, missing, etc… That’s the first one that I’ve seen saying that it has a function callback. Do you get the error in Studio? One thing you can do is submit a bug report over in the Bug Support message category and explain that the error message does not make sense.

The problem with this new tool is that it doesn’t really give any information as to where the error is occurring. A file and line number would be great.

If you’re having issues with ContextActionService, I wrote a complete replacement for it. At least with mine, the errors (warnings) make sense.