DataStor2 Issue (HTTP Unknown Error)

I’ve been using DataStore2 in my games for 2 years now without any issues. Today, when testing my game, whenever I try to stop the game, it freezes for 10-20 seconds, and puts out 2 errors

Not running script because past shutdown deadline


HTTP Unknown Error (TlsVerificationFailed)
in the datastore2 module script.

The game is published, security settings for API are enabled.

1 Like

this might help you

No it might not, completely different error, completely unrelated topic, absolutely not similar to my case. Thanks for copying it here.

No, TLS and SSL are both web certificates

Certificate obsoleted??? Should we report???

I think the datastore2 error derived from the first error - Not running script because past shutdown deadline.

Through annoyingly disabling all of the scripts one by one and testing the game, Ive found that the issue came from a dash script I have (it doesn’t use datastore, but the past shutdown error was because of it). I didnt exactly find out what in the script was causing the error (nothing should have), but after modifying it a little bit, I no longer experience any of the errors

A hunch I have is that the script was firing a remote event that was parented to character instead of replicated storage, and when player leaves, character gets destroyed. But its a very weird issue, because character gets destroyed only after the remote event is fired.

Isn’t data trashed when

Maybe turning ID into string?

I got the same issue, people don’t receive cash when buying it (devproduct). Same error.

Yeah I thought I fixed it but it’s randomly happening again. I also got tlsverification error just when opening the place in studio, without actually playing the game, it is definitely something on their side, either Roblox or DataStore2.