Does Spatial Voice Chat not work on Studio anymore?

Previously, maybe a few months ago, Voice chat worked fine in studio. Now, I don’t even see the bubble, but I do see the bubble when I join the game from Roblox.

This is annoying. Especially when I’m trying to play with the new Audio API. Anyone else having this problem?


I don’t an answer however this is also happening to me, so you aren’t alone. Sad because I also wanted to play around with the new audio API.

1 Like

Yeah same thing here :confused:

Interestingly, Voice Chat still works in Roblox Studio, but any options / UI related to Voice Chat, such as:

  • The mute button above the character or at the top left of the screen
  • The “Input Device” option in the Settings

currently only appears while in a “Team Test” in Roblox Studio (meaning that Team Create has to be enabled).

I hadn’t tested out Voice Chat before the new Audio API was released, so I hadn’t known if this was intentional or not; after reading through the posts here, though, it seems like that’s a bug.

Here’s are some screenshots I previously posted when initially coming across the issue:

Side Note:

I wish it was possible to create a local playtest with 2 or more clients where audio from Voice Chat would be transmitted between Player1 and Player2. This would make it much easier to test situations that would normally require 2 or more players without needing to use multiple devices or constantly invite other players to test things when making lots of changes to audio-related systems.

I’m not aware of a time when Spatial Voice Chat worked in Studio outside of Team Test, but…

You can set Activate on AudioDeviceInput within the Properties menu to use the new Audio API in Studio.

This does work. Spatial voice worked for a while, especially when Voice Chat was brand new. But it seems the upcoming months broke it on studio.