Engine Bug - BasePart Shape randomly switching, Texture glitching, Size glitching, Position glitching


Recently while testing things for a game, I have found out a very critical bug happening; basically everything in a place is getting corrupted. (Textures are getting glitchy, some colors can change, size is glitching, position is glitching, shape is glitching)

In my example, the blue parts get invisible for 2 seconds once you touch them, then turn back visible, and after some tries (sometimes on first try), everything gets glitched.

This is how it should look:

This is the bug after it starts happening: (I have got a lot more where things are getting moved etc., let me know if you need it)

I have tried to identify why it happens and found the script causing it, it is basically a transparency property change clientsided, here is the example place, you can find the quick code I made to reproduce it under PlayerScripts, but it is very simple:

Roblox_Engine_Bug.rbxl (55.0 KB)

To make it simpler I have made it only happen when character touches the part, but pretty sure it happens no matter what when transparency happens. It could also be a mix of everything I use in the script.

local player = game.Players.LocalPlayer
repeat wait() until player.Character ~= nil
local character = player.Character

local CollectionService = game:GetService("CollectionService")

function TouchedHum(otherPart)
	if otherPart.Name == "DisappearAppear" then
		if CollectionService:HasTag(otherPart, "debounce") then
		CollectionService:AddTag(otherPart, "debounce")
		otherPart.Transparency = 1
		otherPart.Transparency = 0
		CollectionService:RemoveTag(otherPart, "debounce")



for _, part in pairs(workspace:GetDescendants()) do
	if part.Name == "DisappearAppear" then
		part.CanCollide = false -- I think it still happens without doing this

How to do it:

  • You need StreamingEnabled off for it to happen (I tried with StreamingEnabled and couldn’t reproduce the bug) (StreamingEnabled can be On, seems to happen less. But still happens with StreamingEnabled)
  • Client needs to transparency, untransparency a part, happens instantly most of the time. If it doesn’t happen rejoin
  • It happens only in Graphic 7 and under apparently (never had it with Graphic 8 and upper, even if it could), if you were on Graphic 8 and upper, set your graphic to 7 and rejoin
  • It doesn’t happen on studio, only on live game
  • It didn’t happen on my phone, would need more testing though. (S21 Ultra)

I also thought it could be my drivers or graphic cards, but I don’t think so since some of my friends tried it and had that bug too.
Here is a test from one of them (@Lyzrinn) :

I have no idea what is happening, and if I should disable something in the game to prevent this! This shouldn’t happen and I’m not 100% sure what is causing this, changing properties clientside should be fine :thinking:, my only thought is that client and server infos are not the same so the client is trying to fix it somehow.

Thanks for reading ! Let me know if you need more informations :slight_smile:
I didn’t see anyone posting something similar but I could be wrong. Please let me know so I can redirect to original bug report if there is one.


It happens with my game too Why does this happen?, occurring randomly in live servers too apparently, try adding unions and meshes with different rendering fidelity to see their behavior

1 Like

It could be the same bug. I remember seeing people reporting it on random games. Two of the game I worked on had a similar bug, but only one person or two reported it (on thousands of players)

I remember a jar in a game going crazy for no reason and half of the map getting destroyed in a pvp game. Only clientsided visual bug.

This is just an acknowledgement reply!

We’ve filed a ticket to our internal database and will follow up when we have updates!

Thanks for the report!


Don’t know if this is related, but the physics have also been a shottier than before after the latest update. Because we haven’t touched the code for the main build in awhile, and all of a sudden we’ve been getting reports of flinging and stuff like this, when it was working fine before.


1 Like

I’ve noticed that there have been a surge of bug reports on a game I worked on regarding people being flinged to the void by going close to enemies when it was fine before. Seeing this post made me believe that there’s a bug with physics. Hopefully this is an issue that can be quickly resolved


Any updates? My game is struggling with the same issue although i did not touch anything regarding rotation in the code and it were working perfectly fine before that update. I hope itll get fixed soon

It is also possible to get flinged randomly

1 Like

This is a bug with the PhysicsSteppingMethod update. Until Roblox fixes it, go under the properties of workspace and set “PhysicsSteppingMethod” to “Fixed” and it should solve this issue. Once they come out with a fix, you can set it back to default or adaptive as I understand that they are more performant options.