Failed to load animation - Sanitized ID: <error: missing assetid> - Studio

I don’t store my Animations in replicated storage for the most part. I use Custom rigs and folders when sorting, so It doesn’t really help me, but thanlks for your reply!

Where do you store those folders?

Many different spots. Mainly inside the rig that uses those animations. The game I’m working on is a animation Heavy game, so there is lots of animations. The rig that uses the animations often has a folder called “Animations” inside the Rig model where my scripts can access them

I’d try to look for those animations that aren’t directly stored in the rig and move them, if there are any. Hopefully Roblox fixes this soon though.

This method worked for me.

I have no idea how or why did the ASSET ID changed, but after checking at

Copy the new assetid and use it, it worked for me

That’s great an all… but how am I suppose to change 100s of animations at a time lol… I’ll see if it works but it’s gonna take a bit

I haven’t yet seen a better solution, but this one helped me. :slight_smile:

1 Like

Did you manage to do it? Did it help? @OfficialPogCat

Unable to verify… but I have done most of them and nothing has changed