Flashing Shadows Lighting Bug

Recently in my game when I play on studio or in a real game I have a bug that causes shadows to flash very fast.

Some Examples of the issue.
https://gyazo.com/79edbe3125278de79c1bbda1d2e23df3
https://gyazo.com/b746d740191b816702b0d126feefe827

Both these are recorded in a real game, but the same thing happens in studio as well.

I didn’t change any lighting-related settings before this so I really have no idea what could cause it.

I don’t know if this is a studio bug or something on my end, but I have a strong suspicion it’s something on my end because I’ve tested other games, and it only happens in my game.

Any Help Would be greatly appreciated - Icecatz

5 Likes

Do other people get this bug when playing your game? Are you using Future lighting? Might be a problem with your drivers. Have you updated them lately?

1 Like

I had this issue on mobile. Also this is in the wrong category this should go in #platform-feedback:engine-bugs

1 Like

This isn’t certain to be an engine bug… Might just be an unsupported driver or lighting misusage. Though you should absolutely post it as a bug if no-one here can help.

1 Like

I would consider it an engine bug because I’ve seen reports of this issue across all platforms (mobile, Xbox, and pc)

1 Like

Yeah, I used miners haven open-source once and had this lighting bug on PC half of the time a server would start up

1 Like

Yeah ive had freinds have this bug
Shadowmap lighting

1 Like

I’m also having this bug on my studio place in particular with FIB3. When I edit and go into studio testing and come back out, every time I move an object when indoors, the surroundings tend to start becoming flashy.

I’m uploading this video to better present and describe the issue. To my surprise, this issue does not occur in-game or in-studio with other lighting technologies.

My graphic API is manually set to Direct 3D11, the same issue occurs when I set it back to automatic. The shadow flash grows more and more dramatic when time progresses, which tends to create risks for some of the developers on the team I’m working with who suffers from photosensitive epilepsy (Wikipedia)

Video:

That looks like a different bug to me, in mine, the flashing shadows only appear far away from the camera and in a circular shape.

(Edit) I’m also using shadow map lighting not future lighting

Then I would suggest filing a bug report. There shouldn’t be issues like this with shadowmap…

I can report that I’ve seen this bug on Xbox One, and Roblox Studio on PC.

It happens to me too so i think its not related about your computer or something

This has been occurring in my game as well, it seems like it has a pretty rare chance of happening, but I’ve seen it happen across a spectrum of devices. Mobile & PC both seem to be affected. I don’t have any videos of it happening right now but once I come across it again I’ll update this. It’s not a big deal but it does seem to annoy the audience

I’d like to bump this topic again. This shadow flash has been reported for a few days from a few players (not the majority of the population) and it is noted that the risk of a player going into seizure is high.

Can we have a fix ASAP? Thank you!
Place:
MCRD San Diego, California (roblox.com)
Sample
https://gyazo.com/cd3e33478ed0613bdcab8d3b6eecd3d5

You should post this as an engine bug if you want roblox engineers to see it.

1 Like

Quite unfortunate that members can’t post in engine bug reports. Only regular+ can.

1 Like

I don’t have high enough permissions to post this in the engine bugs category.

Having the exact same issue on future lighting; disturbs me so much
Only happens when ‘shadows’ property of the light is set true.


Updating graphic driver won’t fix the issue
2 Likes

It happened to me too, but only when I was moving in the studio. I just had to turn off global shadows for it to stop, but now I don’t have any shadows

but i want shadows in my game :weary: