FPS drops when selecting an Instance in Explorer window with Properties window enabled

Reproduction Steps

If you look in the bottom right corner you’ll see that my FPS drops constantly when selecting / deselecting an Instance in the Explorer window.

When I disabled the Properties window my FPS also drops

image

My Laptop Specs

Dell G3 15 3500

OS: Windows 10 Pro
image

GPUs:

  • NVIDIA GeForce GTX 1650
  • Intel(R) UHD Graphics

Expected Behavior
FPS to remain at 60

Actual Behavior
FPS drops by 50%~

Issue Area: Studio
Issue Type: Freezing
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-07-20 00:07:00 (+07:00)
Date Last Experienced: 2021-07-21 00:07:00 (+07:00)

10 Likes

I’ve been having a very similar issue except it isn’t as bad as what’s shown in the video.

Whenever I select an instance in the explorer (haven’t tested with selecting in the viewport yet) my FPS drops by about 4-10.

It seems like the FPS drop is worse when I select an object with a different parent than the previously selected instance.

Computer specs

CPU: Intel i7 3.6GHz with 6 cores
GPU: Nvidia RTX 2070
RAM: 16GB

3 Likes

I have been experiencing this issue as well. It happens when I select stuff or change to any of the studio building tools.

Computer Specs
CPU: Intel Core i7-9750H
GPU: NVIDIA GeForce GTX 1660 Ti
Ram: 16 GB
OS: Microsoft Windows 10 Home (64 bit)
OS Build: 19041.1110

1 Like

Does this still happen if you disable your plugins? See here: How to post a Bug Report - #18 by Roblox
CC @DaDude_89 @Enomphia

The issue continues even when plugins are disabled.

2 Likes

I am experiencing this issue as well, I have not noticed it at first because I don’t usually use the explorer.

1 Like

Can confirm this. Although it’s more of a micro-freeze than FPS drop, atleast for me. This also happens if you click one of these tools:

image

4 Likes

Yes, same. Everything freezes for 1 second, water will also stop moving and other stuff, this is just a big pain in the nose. I have a pretty good pc (i7 10th, rtx 2060S, 16gb ram, 1tb ssd and 1tb hdd both having 800gb+ free). it never occurs on my i5 laptop AND NOT EVEN ON MY FRIENDS INTEL PENTIUM LAPTOP.

1 Like

I’m experiencing the same bug but seemingly exclusively to the three tools (move, scale, rotate) - I haven’t noticed anything when selecting parts without altering them. This only started with the most recent update; I have tried uninstalling and using without plugins.

5 Likes

This has been happening to me for about 1 year now and it hasn’t stop. Its also getting worse. The longer you are in roblox studio for, the worse it gets. Even with the properties and explorer tabs close, it still happens. I have a very beefy computer so this shouldn’t really be a problem for me.

Video of bug

System specs:
GPU: NVIDIA GeForce GTX 1650
Processor: Intel Core i7-3770 CPU @ 3.40GHz 3.40 GHz
RAM: 16.0 GB
OS: Windows 10 64 bits

I used to have this issue on my older computer. One day it just decided to drop frames harder than ever before and decided that I should just get 30fps everytime I want to enjoy building.

I have been experiencing a very similar issue. My fps only drops by about 1 and quickly goes back up while selecting instances. However, if I pick them up and start to drag them elsewhere, my fps DROPS.

Video of the issue (watch the fps counter in the bottom left):

Laptop Specs:

  • Windows 10 Home
  • 8GB RAM
  • Intel Core i7 2.59 GHz
  • 512GB SSD
  • NVIDIA GeForce GTX 1650
1 Like