Gamepass image link refuses to update

On October 1st I made an update where I released a new gamepass. My interface uses this line:

To get the image of the gamepass. Except it doesnt work for that specific gamepass, the image I updated it with around September/October 1st never updated to what it should be, check out the same gamepass id link:

I was forced to write a line of exception in my script just to acknowledge this particular gamepass has an overriding image.

I tried updating the image of the gamepass a day later, it was still not updating to that image link. I’ve never had this happen before, nor did it for another gamepass of that same update.

This isn’t a bug. Game passes are no longer assets so you have to get the image separately using the new ID (You’re using the old one)

game:GetService("MarketplaceService"):GetProductInfo(3178145, Enum.InfoType.GamePass).IconImageAssetId

You can find out more here if you haven’t seen

Its a bug, the image should be updating, just like the other one did. Its not a new gamepass, thats why it has an old id while new gamepass have no old id

Out of the 50+ gamepasses I have, this is the only one with the problem, others have been updated recently and work fine. This is a random exception, and I dont believe roblox would support this behavior, which is why I would call it a bug.

As mentioned here ,gamepasses have their own system. All old gamepases were converted to the new system so now have a new ID. Updating the image through the configure page will update the new version, requiring you to use the new system

I am aware of the new gamepass system, thank you for informing me on that one. I still think this is a bug and not what the engineers intended, just wanted to bring it to light. I’ll be using the new system in the next update.

1 Like