Has anyone ever ran into this problem while unioning?

Never seen this before but it has just happened when unioning a few brick parts.

Pre-Union; http://prntscr.com/kofx9a
Post-Union; http://prntscr.com/kofxcv

As you can clearly see unioning these parts somehow manages to move the middle piece towards the right.

I did the same thing with another section to no avail, the result remained the same.

Pre-Union; http://prntscr.com/kofxt0
Post-Union; http://prntscr.com/kofz7j
NOTE: Only unioned the bottom layer of the build.

I tried unioning a few other things, they worked out fine however. Any ideas?

1 Like

I overlap my Parts by .01 to get rid of that issue. I haven’t seen it that obvious before, usually just .001 stud or so.
Either that or don’t Union Parts together, just Negate the corners off for something like that first example.

Maybe it has something to do with floating decimal errors for Position of the Parts?

I tend to go with the Negating option. Sometimes with adding Parts to each other, even if you get the edge to edge surfaces lined up or overlapped, the flat “top” surface still produces a visible line because the 2 Parts aren’t at exactly the right level.

You can fine tune Position by using .0001 stud increments in the Properties window, but it isn’t visible unless you are right next to the Union or the light shines off it just the right way.


Problems persisted while overlaping parts. Problems persisted while using negating instead. Despite resizing multiple times it still puts it off. Never seen anything like this before.

1 Like

You didn’t go into your Studio Settings and toggle off the CSG2 setting did you?
Or use Unanchored Parts?

Try this:

That’s intended behavior. The new CSG system offsets parts by a small amount to prevent any errors from happening.

With that being said, you could probably move the model a bit and then union it. Then the offset might put it in the right spot again.

1 Like

No and no.

Did not work, any other suggestions?

An additional problem seems to have surfaced.

I was attempting to make a bowl from unioning through negation however it seems be all kinds of messed up.
I go about it the regular way, starting with a single sphere; http://prntscr.com/kotc8d
I then copy the sphere and resize it by .125 on all sides with the intent of negating it to make the sphere hollow; http://prntscr.com/kotcq4
When I try to make the inner sphere a negative part it moves itself slightly, offsetting as you all are saying. So I undo it, copy the position of where it was supposed to be at, and paste it when I make it a negative part again so that it is in the center of the sphere I want to make hollow. When I finally union the inner sphere(negative part) and the outer sphere, this monstrosity presents itself before me…; http://prntscr.com/kotepl

At this point, I’m at a loss. Absolutely baffled. So I undo to before I union both parts and I move the outer sphere to unveil the beast; http://prntscr.com/kotf5r

Now this, I can say with a indisputable degree of certainty, is something I have never seen before.

You could try it with CSG V1. No idea how that would go.

I would also try making these in a new place file… It could be something weird with your current one.

Just tried it at a few other places, the results are the same. The results are a little more tame but still problematic; http://prntscr.com/kotmrk | http://prntscr.com/kotnel

Disabled CSG V2, it solved the sphere problem. However it wont even let me union the set of bricks I was having my initial issues with. It wont let me union every part without; http://prntscr.com/kotq5x

It sounds like a bug. You should report it.

1 Like

It is. [SOLVED] CSG Causing malformed shapes and physics?

linearcomplex had the problem resolved.

Thanks to everyone who tried to help resolve the matter.