Having an issue with Viewport Frames

Hey, so I’m working on a character display frame in which will show you a visual of whatever outfit you’re selecting from the menu. So I put in an R15 rig, which renders fine. I call a function in my module to update the appearance of the rig, but I notice no rendering changes on the frame. Interestingly enough though, when I copy/paste the rig from the viewport into Studio, it has all the correct accessories/clothes on, but I don’t see this on the viewport frame.

Any help appreciated, can provide code but it’s nothing that special…just wondered as to why this result might be happening, thanks.

A post was merged into an existing topic: Off-topic and bump posts

Can you show it to us anyway? Physics doesn’t work in ViewportFrames, so updating stuff such as accessories, motors, etc. won’t take effect.

(related. Welding accessories to a character)


Ah I see. Yep, it’s because I welded some parts (hats and so fourth) to the rig, which doesn’t render apparently.

I think I can work around this though. Thanks for the help. :slightly_smiling_face:

Okay so, what I tried ultimately failed…I assume there’s no work around to achieve this.

I tried instead of welding, to set primary parts of my models and to simply set their CFrame onto the rig. This failed to work as well.

Any help appreciated, thanks

Show us the code :slight_smile:

1 Like

Whoops, I completely forgot to add something, so therefor the new function I wrote never even ran.

I feel dumb now :joy:

Thanks for the help guys!

1 Like