Having Trouble with AnimationTrack:Play()

Tested and it actually reached there (Dont worry you helped alot! Ima try asking for a Roblox Admin something like that on this issue or consider this an engine bug!)

1 Like

do a test, place a animation in the script and do Humanoid1:LoadAnimation(script.Animation)

1 Like

Don’t worry the animation is not a link, is just inside a folder and i loop inside that folder to find it!

1 Like

Your loading the actual animation object, not the ID

1 Like

Im loading the actual animation object actually

1 Like

so this is a local script, in StarterCharacterScripts? And NPC1 is a NPC ingame?

1 Like

It is a local script, but in starterplayerscripts. And yes the Npc1 is ingame (Sorry for answering so late i was looking trough the roblox forum for this situation, and i cant set this as a Studio Bug so oooooooooooooooof)

so if the NPC1 is a character, your loading the animation in to the NPC. not yourself

1 Like

Well that’s what im trying to do actually, set into the Npc1

1 Like

oh. Well, sorry to say to load a animation into a NPC, you need a non local script somewhere thats not the player, like workspace. if you want to control it from the player use a fire server event

1 Like

Well I actually tested in a script in a workspace before following the same lines that we are discussing about, i’m sorry if i dint say you that

if you have a script in the NPC, just write something simple like

Humanoid = script.Parent.Humanoid
Anim = Instance.new(“Animation”)
Anim.AnimationId = AnimationID

Oh i forgot to say, the Humanoid:LoadAnimation is deprecated and now they recommend to use the actual Animator, here’s the link to the post: Deprecating LoadAnimation on Humanoid and AnimationController

then in your script with the problem replace Load:Play() with

AnimationID = ChosenAnimation1.AnimationId game.ReplicatedStorage.AnimationEvent:FireServer(AnimationID)

Ngl that’s something actually very smart and efficient i guess, but idk if I could actually track the time of the animation with that, just maybe (Also it still doesnt work)

1 Like

I used Humanoid:LoadAnimation() Here and it worked fine

so Im sure that it shouldn’t create any problems, they even say its fine to keep using it

Yeah it’s just an extra parent for animator actually but I think on the actual player it works, now on Npc’s somehow they dont so yeah (Also pogs gameplay)

Well I still din’t figure out, and i dont have the permissions to do a post about engine bug, now im without ideas but you helped actually alot man, Thanks for trying!

its okay, Im always here if you need also just tried it out still works on the NPC’s fine


also ingore how I missed point blank

Lol and b r u h so mine Studio is really bugged welp, anyways thank you!