Hold Animation Is Not Working As Intended

I have a hold animation for my tool. I made the animation in the Animation Editor window and exported it. The animation looks good in the animation editor window but when my player equips the weapon, the hold animation does play but it is not played exactly the way it was played in the animation editor.

Animation Editor:

What it looks like my player actually holds it:
As you can see, there is something definitely wrong especially with the right hand.
This problem also occurs in other animations.

I even tried changing my body type to the same as in the animation editor and here are the results:
As you can see there is something wrong with the right hand only. The rest of the animations is looking good.
I even tried it with another tool:

I am doing the animations from this post:

Things I have tried:

  • Adding keyframes to the right hand (no success)
  • Settings priority to action (no success)

Any help would be appreciated

1 Like

If you are using a tool, roblox automatically welds the tool to the right hand
And if that’s not the case, you can ask for help in #help-and-feedback:scripting-support

1 Like

I am using a tool. But I have disabled the property “RequiresHandle”

If the handcuff tool you used is a freemodel, the script might be made for
R6 only (because of your broken right hand)

Again, please move to #help-and-feedback:scripting-support and ask others there for help with the script you have since I’m just new to programming so my knowledge is limited with this kind of stuff.

My friend made the Handcuff model and I scripted it. And if it might be helpful, I am doing this from this post: