How can I convert a camera from a 2D style to the main style Roblox uses?

I have tested the exact script that you sent, and it worked perfectly. Do you have any other scripts manipulating the camera?

In fact, I actually do. A LocalScript in StarterCharacterScripts.

local RunService = game:GetService('RunService')

local CameraManipulated = false
local debounce = false

	if CameraManipulated then
		workspace.CurrentCamera.CFrame = workspace.SpikeNPC.Camera.CFrame
		CameraManipulated = false

	if game.Players.LocalPlayer == game.Players:GetPlayerFromCharacter(hit.Parent) then
		if debounce == false then
			debounce = true
			CameraManipulated = true
			workspace.CurrentCamera.CFrame = *,0,60)
			debounce = false

This script was meant to activate an animation that moves the camera. The camera is rigged because rig animation is my specialty.

Do you still require this script? If not, I recommend just deleting it, otherwise, if you do still need it. Can you please explain what exactly its needed for, and if you actually touched workspace.AnimPart in that video you posted?

First of all, in the original posts video, I actually touch a part called CameraTo3D, the AnimPart is a completely different trigger.

This video here is what the second script is for.

Okay, so can you check for me one more time, is there any other script that manipulates the camera or does something with the camera in any way?

There are no other scripts that manipulate the camera.

Are you certain that the camera is actually broken? Have you tried rotating the camera with your mouse or arrow keys? If this is the case, how does your character heirarchy look, that might be causing issues.

I have tried using the mouse, and just now tried the arrow keys. They do not work.

Also, what is the hierarchy in this case, is that like the characters rig?

Correct, could you please attach an image of the characters rig? In addition, could you use the find all window, and type in CurrentCamera, and see what pops up. Check if there are any unrecognized scripts.

The item I have highlighted in the explorer is the rig, showing all the instances.

Can you press play and show a picture of the character heirarchy then? It might look different in game.

local function onUpdate()
	if player.Character and player.Character:FindFirstChild("HumanoidRootPart") and Camera2D == true then
		camera.CFrame = *,0,60)
	elseif camera.CameraSubject ~= player.Character.Humanoid then
		camera.CameraSubject = player.Character.Humanoid
		camera.CameraType = Enum.CameraType.Custom
		camera.FieldOfView = 75

try this.

That didn’t work.

Also, I just now tried making a new baseplate and testing the script, it seems like the script just doesn’t work at all for me.

Was that the only script in the baseplate place? And was it in StarterPlayerScripts?

Yes to both questions. I have checked the baseplate, and made sure I put the script n the right place.

Could you attach the baseplate place so that I can test it?

Baseplate.rbxl (35.5 KB)

Also, it’s currently 1:06 AM for me, so I’m going to need to go and sleep.

If it helps, here is the link of the post I got the camera script from then edited. (I only did Step 1)

Okay, so I managed to fix this issue by just changing the name of the script from “CameraScript” to “LocalScript.” I honestly have no idea why that is the issue, but I believe it has something to do with Roblox using that same name for their core scripts. I believe you can change it to anything that you want, other than “CameraScript.” I changed mine to “CameraStyle” and it still works.

I tried this, for me the result was whatever this is.
I’ve been trying to make this work for like 2 months now on my own and also based on devforum posts without success. Can I get some help?