How can I remove the sun from reflections

The title is pretty self explanatory, I want to remove the sun from reflections, I have celetialbodies off, sun angular size to 0, no sun texture, and it still shows on material reflections.

I don’t think you can get rid of the reflection but you can try turning down the bloom by going to lighting > add bloom > then reduce the bloom, as well as increase when it becomes bloom.

check this post: Add an option to remove sun glare/reflections on parts - #3 by nooneisback


Change the “Reflectance” property of all part instances to 0, this will prevent them from reflecting any atmospheric color.