How do I disable avatar pants in Avatar Settings?

I was able to enable avatar pants from the Game Settings, but now it doesn’t show on there anymore.

How do you disable avatar pants? I want players to use their own pants.

If you want players to use their own clothing, you shouldn’t need to touch that in anyway. As this is just an easier way of overriding their avatars clothing.

1 Like

The game gives everyone the pants that I entered in Avatar settings. I can no longer disable the feature, that is the problem.

Maybe take a look at changing your system to humanoid description. New API For Equipping Assets on Humanoid Player Avatars

If I recall correctly, pants were disabled due to safety and rules concerns because I do remember a pants toggle being there in the past. Overkill if that’s the reason but rules I guess.

If the toggle isn’t there, there’s no way to disable it. I skimmed properties as well, no such way to disable it via the command bar. You’ll have to transfer everything to a new file or write code to override the default pants.


Oh then the only thing you really can do is move the game to a different place

I appreciate your help and everyone else’s, thank you :slight_smile:

With release 420 it’s now possible to override avatar pants again!