How to animate a tool/object with a Dummy in the Animation Editor

This is the only way to replicate changes to the server in this case, why does it cause huge lag and delay?

I mean… not an exactly huge lag, but I don’t wish there’s a delay. Is there possible way to replicate or simulate the behavior like the Roblox Tool does? Users when lagging with high ping will have heavy issues on equipping.

1 Like

Create a script in your tool for handling the Motor6Ds, and the RightGrip as well. Things done on the server automatically replicate to the client, unless in special containers (Server Storage, Server Script Service, ect.)
The client should be handling the animations, though.

1 Like

Script works in a tool? Never knew that though.
I made my own way to simulate this behavior but it may seems “wacky”, first I called the server to create a Motor6D, then I create another Motor6D on the client. When the server Motor6D is being created, the client on will be voided.

rp.ConnectM6D:FireServer(ShotgunTool.BodyAttach)
	
local m6d = Instance.new("Motor6D",char.Torso)
m6d.Name = "ToolGripCLIENT"
m6d.Part0 = char.Torso
m6d.Part1 = ShotgunTool.BodyAttach
m6d.C1 = CFrame.new(-1.8,1.5,-0.2)


repeat wait() until char.Torso:FindFirstChild("ToolGripSERVER")
m6d:Destroy()

Yeah, this looks wacky and ridiculous but I think it works, I might reference your scenario if this way is inconsistent in different occasions.

1 Like

All scripts run if they are in the workspace, so yes, they work in tools

@H_mzah @mistrustfully I think I kinda fully solved this!
(@/H_mzah you might wish to add the following to this tutorial:)

Edit: Check out this walk-through guide:

A tool’s handle can not be animated, it would not play in game if you tried to animate it. If you wish to move your tool’s handle freely for animations like knife tricks (CS:GO knife admiring animations, etc.), you should do the following.

First, put your tool inside an animating dummy, rename your tool’s handle to something else but not Handle. For some reasons the Motor6D will offset few studs if it’s called Handle no idea why, probably because of Roblox’s tool. I called it BodyAttach.

Secondly, use the Custom Character Creator Plugin, select the dummy model and select “bind” in the plugin, it will require you to select two parts to bind with, select the torso and BodyAttach.

Thirdly, bind BodyAttach with other remaining parts on your tool, for some reasons you must use the plugin to create the Motor6D, do not attempt to create the motor6D by yourself, or else parts will go offset even though there are welds and can not be reverted to it’s original position by pressing undo.

Fourthly, after binding all parts, you are ready to animate! Open the animation editor and you will see Left Arm, Right Arm, Left Leg, Right Leg and BodyAttach, you can now freely animate your tool, including it’s handle!

Lastly, copy the tool you just animated (the one that was inside the animating dummy) and put in StarterPack, all of the Motor6Ds inside BodyAttachshould stay constant and make sure they exist when you run the game. What you want to do now is create a Motor6D when the tool is equipped, the Motor6D’s Part0 should be Torso and Part1 should be BodyAttach. Make sure this have to be done in the server! you can reference the script above.

And here’s how you create a tool without a handle, also how to freely animate a tool’s handle! If you have any questions feel free to mention me. :slight_smile:

29 Likes

Basically, I tried doing that, and instead of the gun being positioned correctly, it was immediately mispositioned.

Any thoughts on how I can fix it?

2 Likes

I’d start of by checking and fixing the handles. Sometimes the handle works differently in studio and in-game.

What exactly do you mean with checking the handle?

Make sure that they’re positioned where they’re supposed to be and welded correctly.

2 Likes

Your character will hold the tool by the Handle usually. I suggest making the Handle an invisible break that doesn’t add to the aesthetic of the gun. This means you can move it around to find a good position where your character is holding the gun as you’d like it to. It’s mostly trial and error, so adjust the Handle until you like where it is.

2 Likes

I’m trying to animate a musket I just created, but the positions of the handle while holding and playing is different from how I positioned it in studio. I followed this tutorial to the step, including using Custom Character Creator to bind the Motor6D’s and removing Welds on the parts you’re animating.

How it looks ingame:

How it looks in studio:

I’m also getting this weird thing where I try to select/rotate specific parts, the animation editor does the moving and rotating from the position of the handle regardless of where that specific part is.

Example:

I’m aware that my SBS plugin (building plugin) is displayed in my screenshot. SBS was never used.

Any assistance would be appreciated. Lovely tutorial! :drooling_face:

3 Likes

Are you using Motor 6D to connect the character to the tool? If so, use Motor6D.C1 to position it correctly.

Yeah, my handle is the invisible brick, but even with the animation set to how I want it to be, the gun still self-aligns itself with the player’s arm.

Make sure all the parts are connected to the invisible part through Motor6D?
I recommend you to check out my walk-through guide here.

Annoyingly, the animation editor won’t let me select and manipulate the handle, even though all joints and everything have been set up properly. it’s even shown as a joint

Edit: This looks like a problem with the beta animation editor, old one is working fine. This is what I get for wanting to use features before they’re fully released.

3 Likes

It seems the ability to edit the specific joints of weapons has been broken by the new animation editor. Any word on a fix?

I’m currently unable to work on a fix for this due to university work unfortunately. If anyone has a fix and wants to contribute I’d be more than happy to add it to the main post with credit provided. If there isn’t a fix soon I will work on coming up with a solution myself.

I tried a lot of time and i cant make it pls help me ;-;

1 Like

Hi, if you’d like some help I suggest going into more detail about the problem, a repro file would be highly appreciated. Without a clear image in my head of what you are trying to achieve I’m not able to assist you.


@awesomeboy9000 I’m currently looking into a fix for the issue with the new Beta Animation Editor.