I can't open the Appearance Dropdown

Appearance will not open when clicking the dropdown button

What I tried so far:

  • Restarting Studio
  • Restarting my PC
  • Resetting Studio Settings
    Neither of these have fixed the issue.

Expected behavior

The appearance dropdown should open upon clicking.


It appears as if the first dropdown of each properties menu is now locked, if you previously had it open, it now is locked open and unfortunately in your case, if you previously had it closed, it is now locked to be closed. This appears to be a recent regression in behaviour.


ok just closed by accident and uhh i cant reopen it
reluctant to uninstall studio but i think that’s the only way

top tip:
dont uninstall, it doesnt work still


I’m having the same problem. Ugh.


To temporarily fix the issue, I’m sure you can try this:


I just tried this and it did not work, I really hope this is fixed soon. This bug is horrible.

1 Like

Update: I have no clue what I did but I spam clicked and it fixed???

It appears it works if you tap on the right side of the appearance dropdown, the part without the text or the arrow, and if you double click it it’ll open/close.

This seems to be an issue with the text/arrow overlaying the interaction button in studio for the appearance dropdown, causing it not to open when clicking over that.


Hi, can confirm we’re seeing this on our end and are looking for a solution. Double clicking in the middle of the bar is the short term workaround for this - can anyone experiencing the issue _not _ get the section open/close by doing this?


While we are fixing this, the workaround is to click to the right of the “Appearance” header (the area marked purple on the screenshot)


Having the same issue here,


1 Like

A fix: Click the right side of the Appearance tab.


More accurately, there’s an object in the corner that’s blocking mouse input:



This issue is still happening.

1 Like

It has been a long time now. Roblox hasn’t fixed this issue.

1 Like

thank you!!!

1 Like

I am not sure if you’re still facing this problem but you can fix this by double clicking the appearance bar and not clicking on the arrow.

That should fix your problem hope it helped :slight_smile:

1 Like

This issue is the same bug from this thread:

As i’ve replied there, the fix will be released in January!

can someone please explain

well, this was fixed a long time ago, whoever bumped this, i thought it was new, but wth is this?

This bug was caused by the top left corner of the properties window being unclickable, and by default, appearance is at the top. Hence, it’s been filed as the Appearance dropdown being unopenable.

I’m glad to let you know that this was fixed last week!